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Warranties and Declarations 

Copyright 

The copyright of this document belongs to Qingdao Hantek Electronic Co., LTD. 

Statement 

Qingdao Hantek Electronic Co., Ltd. reserves the right to amend this document without prior notice. 

Qingdao Hantek Electronic Co., Ltd. promises that the information provided is correct and reliable but 

does not guarantee that this document is free from errors. Before using this product, please make 

sure that the specifications of relevant technical documents are the latest effective version. If you use 

documents or products of Qingdao Hantek Electronic Co., LTD and need products, patents or works 

of third parties to cooperate with them, you shall be responsible for obtaining the consent and 

authorization of the third parties. The above consent and authorization shall not be the liability of 

Hantek. 

Product certification 

Hantek certified DSO2D20 series oscilloscope to meet China's national industry standards and has 

passed the CE certification. 

Contact us 

If you have any questions when using the products of Qingdao Hantek Electronic Co., LTD., you can 

obtain service and support through the following ways: 

Email: service@hantek.com, support@hantek.com 

Website: http://www.hantek.com

http://www.hantek.com/
http://www.hantek.com/
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1 Safety requirement                     

1.1 Summary of general security issues                   

Read the following safety precautions carefully to avoid injury and to prevent damage to 

this product or any product connected. To avoid possible dangers, please use this 

product in accordance with the regulations. 

⚫ Only professionally authorized personnel can perform repairs. 

⚫ Use the right power cable. 

Use the power cable approved by the country in which the product is used only. 

⚫ Connect and disconnect correctly. 

Before connecting the probe to the circuit being measured, please connect the 

probe to the oscilloscope first. Before disconnecting the probe from the 

oscilloscope, please disconnect the probe and the circuit under test first. 

⚫ Ground the product. 

To avoid electric shocks, the product is grounded through a grounding conductor of 

the power cable. The grounding conductor must be connected to the ground before 

connecting the input or output terminals of the product. Ensure that the product is 

properly grounded. 

⚫ Connect the probe properly. 

The ground wire of the probe is the same as the ground potential. Do not connect 

the ground wire to high voltage. 

⚫ View all terminal rating values. 

To avoid fire or excessive current, please check all rating values and signs on the 

product. Please consult the product manual for details of the rating values before 

connecting the product. 

⚫ Do not operate with the cover open. 

Do not run the product with the cover or panel open. 

⚫ Avoid circuit exposure. 

Do not touch exposed connectors and components after power is switched on. 

⚫ Do not operate if the product is suspected to be faulty. 

If you suspect that the product has been damaged, please ask qualified 

maintenance personnel to check it. 
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⚫ Maintain proper ventilation. 

⚫ Do not operate in a humid environment. 

⚫ Do not operate in inflammable or explosive environment. 

⚫ Please keep the product surface clean and dry. 

Warning: 

Equipment that meets Class A requirements may not provide adequate protection 

for broadcast services in residential environments. 

1.2 Security terms and signs                            

Security terms in this manual: 

Warning: 

Indicates that the operation may not cause immediate damage to you. 

Note: 

Indicates that the operation may cause damage to the product or other property. 

Safety terms on products: 

Warning: 

Indicates a potential hazard may be caused to you if you do not perform this 

operation. 

Safety signs on the product: 

Hazardous 

Voltage 

Safety 

Warning 

  

1.3 Measurement category                                

Measurement category 
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This instrument can be used for measurement under class I. 

Warning: 

This instrument is only allowed to be used in the specified measurement class. 

Measurement class definition 

⚫ Class I refers to measurements taken on a circuit not directly connected to 

the main power supply. For example, measurements made on circuits that are 

not exported from a main power supply, especially from a protected (internal) main 

power supply. In the latter case, the instantaneous stress will change. Therefore, 

the user should understand the instantaneous capacity of the instrument. 

⚫ Class II refers to measurements taken on a circuit directly connected to low-

voltage instruments. For example, measurements made on household 

appliances, portable tools, and similar equipment. 

⚫ Class III refers to measurements taken on construction equipment. For 

example, measurements made on switchboards, circuit breakers, circuits 

(including cables, busbars, junction boxes, switches, sockets) in fixed equipment, 

as well as equipment for industrial use and certain other equipment (for example, 

fixed motors permanently connected to fixed instruments). 

⚫ Class IV refers to measurements taken at the source of low-voltage 

equipment. For example, measurements made on electricity meters, primary 

overcurrent protection equipment, and pulse control units. 

1.4 Ventilation Requirement                             

This oscilloscope uses a fan to force cooling. Please make sure that the air intake and  

exhaust areas are free from obstructions and have free air. When using the 

oscilloscope in a bench-top or rack setting, provide at least 10 cm clearance beside, 

above and behind the instrument for adequate ventilation. 

Note: 

Inadequate ventilation may cause an increase of temperature in the instrument, 

which would cause damage to the instrument. So please keep the instrument well 

ventilated and inspect the air outlet and the fan regularly. 

1.5 Working Environment                                

Temperature 

Operating: 0°C to 50°C 

Non-operating: -30°C to 70°C 

Humidity 
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⚫ Operating: 

Below +30°C: ≤95%RH (without condensation) 

+30°C to +40°C: ≤75%RH (without condensation) 

+40°C to +50°C: ≤45%RH (without condensation) 

⚫ Non-operating: 

Below 65°C: ≤95% RH (without condensation) 

Warning: 

To avoid short circuit or electric shock, do not operate the device in a damp 

environment. 

Altitude 

Operating: below 3 km 

Non-operating: below 15 km 

Installation (Overvoltage) Category 

This product is powered by mains conforming to installation (overvoltage) category II. 

Warning: 

Ensure that no overvoltage (e.g. from lightning) reaches the product. Otherwise, 

the operator may be in danger of receiving electric shock. 

Installation (Overvoltage) Category Definitions 

Installation (overvoltage) category I refers to signal level which is applicable to  

equipment measurement terminals connected to the source circuit. Among these  

terminals, precautions are done to limit the transient voltage to a low level. 

Installation (overvoltage) category II refers to the local power distribution level  

which is applicable to equipment connected to the AC line (AC power). 

Pollution Degree 

Pollution Degree 2 

Pollution Degree Definition 

⚫ Pollution Degree 1: No pollution or only dry, nonconductive pollution occurs. The 

pollution has no effect. For example, a clean room or air-conditioned office 

environment. 

⚫ Pollution Degree 2: Normally only nonconductive pollution occurs. Temporary 

conductivity caused by condensation is to be expected. For example, indoor 

environment. 

⚫ Pollution Degree 3: Conductive pollution or dry nonconductive pollution that 

becomes conductive due to condensation occurs. To be found in industrial 

environment or construction sites (harsh environments). For example, sheltered 

outdoor environment. 

⚫ Pollution Degree 4: The pollution generates persistent conductivity caused by 
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conductive dust, rain, or snow. For example, outdoor areas. 

Security level 

Class 1 - Grounded products 

1.6 Care and Cleaning                                     

Care: 

Do not expose the LCD to direct sunlight for a long time when storing or placing the 

oscilloscope. 

Cleaning: 

If the oscilloscope and probe are inspected frequently as required by operating 

conditions, clean the outer surface of the instrument by following the following steps: 

1) Use a lint - free cloth to remove the dust outside the oscilloscope and probe. Please 

be careful to avoid scratching the smooth display filter material. 

2) Clean the oscilloscope with a soft cloth soaked in water. For a more thorough 

cleaning, use a aqueous solution of 75% isopropyl alcohol. 

Note: 

In order to avoid damaging the surface of oscilloscope or probe, do not use any 

corrosive reagent or chemical cleaning reagent. 

Warning: 

Before powering on the device again, ensure that the device is dry enough to 

avoid electrical short circuit or personal injury caused by moisture. 

1.7 Environmental Considerations                        

The following symbols indicate that the product complies with the requirements of 

WEEE Directive 2002/96/EC. 

 

Equipment recovery: 

Producing the device requires the extraction and use of natural resources. Some 

substances contained in the equipment may be harmful to the environment or human 

health if the product is not disposed of properly. In order to avoid the release of harmful 

substances into the environment and reduce the use of natural resources, it is 
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recommended that appropriate methods be used to recycle this product to ensure that 

most of the materials can be correctly reused. 
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2 Product features                       

Product features 

⚫ Support 1MΩ/50Ω impedance switching to ensure signal integrity; 

⚫ The sampling rate of the entire system is 2GSa/s, with a maximum bandwidth of 

500MHz; 

⚫ Built in arbitrary waveform generator, capable of outputting 5 standard waveforms, 

supports custom arbitrary waveform output, and supports burst output; 

⚫ Protocol Trigger: Comes with five standard serial protocol triggers and decoding, 

supporting protocols including UART, LIN, CAN, SPI, IIC, making it easy to analyze 

serial bus data; 

⚫ 32 automatic measurement and threshold measurement functions, with test results 

supporting statistical analysis; 

⚫ Two sets of digital voltmeter functions and hardware frequency meter 

functions;Standard SCPI remote control instructions, convenient for users to build 

testing systems; 

⚫ Save and export function, which can save settings CSV, Information such as 

images, reference waveforms, and waveforms; 

⚫ Four sampling methods: normal, average, peak, and high-precision; 

⚫ 14 operating languages, supporting over 90% of countries and regions worldwide; 

⚫ There are two cursor measurement modes: manual and tracking, and the Math 

function also supports cursor measurement; 

⚫ 500uV-10V vertical measurement gear, 300VCAT Ⅱ withstand voltage input; 

⚫ FFT scale display, convenient for reading results; 

⚫ Manual, single time, one click AUTO measurement, simple and fast waveform 

measurement; 

⚫ XY mode supports dual window display, making it easy to understand waveform 

phase changes; 

 

The DSO2D20 series digital oscilloscope has comprehensive functions and outstanding 

performance, with a sampling rate of 2GSa/s and a maximum bandwidth of 500MHz 

across the entire range. Support 1MΩ/50 Ω impedance switching to ensure signal 

integrity; Built in arbitrary waveform generator, capable of outputting 5 standard 

waveforms and supporting custom arbitrary waveform output; Standard configuration 

includes 9 triggering modes including edge, pulse, video, slope, timeout, window, code 
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pattern, interval, and under amplitude, as well as 5 bus analysis and protocol decoding 

functions including UART, LIN, CAN, SPI, and IIC; 32 automatic measurement and 

threshold measurement functions, with test results supporting statistical analysis; Two 

sets of digital voltmeter functions and hardware frequency meter functions; Standard 

SCPI remote control instructions, convenient for users to build testing systems. 
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3 Document overview                    
This document describes how to quickly understand the front and back panels, user 

interfaces, and basic operation methods of the DSO2D20 series digital oscilloscopes. 

Tip: 

The latest version of this manual can be downloaded at (http://www.hantek.com). 

Document number: 

 202506 

Software version: 

Software upgrade may change or increase product functionalities, please pay attention 

to Hantek website for the latest version. 

Document format conventions: 

1 Virtual keys and main interface icons 

Use [name] to represent virtual keys and main interface icons. For example, [Utility] is 

for . 

2 Menu 

Use "menu text (bold) + color" to represent a label or a menu option. For example, 

Sound means turn on or off sound of the machine operation. 

3 Operation steps 

Use "->" to represent the next step. For example, [Utility] -> Language means click 

Utility label before clicking Language menu. 

Document content conventions: 

DSO2D20 series tablet oscilloscope consists of the following models. Unless otherwise 

specified, this manual uses DSO2D50 as an example to describe the DSO2D20 series 

and basic operations. 

Model Channel Sampling Rate Bandwidth Signal Source 

DSO2C20 2 2GSa/s 200MHz - 

DSO2C35 2 2GSa/s 350MHz - 

DSO2C50 2 2GSa/s 500MHz - 

http://www.hantek.com/
http://www.hantek.com/
http://www.hantek.com/
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Table 3.1 Model

Model Channel Sampling Rate Bandwidth Signal Source 

DSO2D20 2 2GSa/s 200MHz 1 

DSO2D35 2 2GSa/s 350MHz 1 

DSO2D50 2 2GSa/s 500MHz 1 
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4 Quick start                             

4.1 General examination                                  

Check the shipping package 

After receiving the oscilloscope, please follow the following steps to check the 

instrument: Check whether there is any damage caused by transportation: If the 

packaging cartons or protective foam pads are seriously damaged, please keep them 

until the whole machine and accessories pass the electrical and mechanical testing. 

Check the accessories  

The details of the accessories are provided in Appendix A: Accessories at the end of the 

user manual. If you find any accessory missing or damaged, please contact the dealer 

responsible for this business. 

Check the machine 

If you find the instrument is damaged, not working properly, or unable to pass the 

performance test, please contact the dealer responsible for this business. 

4.2 Appearance and dimension                          

 

Figure 4.1 Front view 
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Figure 4.2 Side view 

4.3 Preparation before use                                

1. To Adjust the Supporting Legs 

There is a bracket design at the bottom of the machine, and the bracket should be 

adjusted appropriately to tilt the oscilloscope slightly upwards, which can better stabilize 

the placement of the oscilloscope and facilitate observation and operation. When not 

using the machine, simply close the bracket. 

2. To Connect to AC Power 

The specifications of the AC power supply that this oscilloscope can input are: ~100-

120V,50/60/400Hz;~100-240V,50/60Hz;50Watts MAX. Please connect the 

oscilloscope to the power supply using the power cord provided in the attachment, as 

shown in the figure. 
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Figure 4.3 To Connect to AC Power 

Warning: 

To avoid electric shock, ensure that the instrument is correctly grounded. 

3. Turn-on Checkout 

When the machine is properly plugged in and the oscilloscope is powered on, press the 

power button in the lower left corner of the front panel to start the oscilloscope. During 

the startup process, all the button lights on the front panel will light up for a few 

seconds, and the oscilloscope will perform a series of self checks. After the self check 

is completed, the startup screen will appear. 

4. Function Inspection 

⚫ Click on [Default Setup] in the button area to restore the oscilloscope to its 

factory settings. 

⚫ Connect the grounding crocodile clamp wire of the probe to the grounding 

terminal in the figure below. 

⚫ Connect the probe to the input terminal of channel 1 and the compensation 

signal output terminal marked in the figure below. 

 

Figure 4.4 To Use the Compensation Signal 
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⚫ Set the probe attenuation ratio to X10 and click on the button area [AUTO 

SET]. 

⚫ Observe the pictures on the waveform to see if the square wave signal is 

displayed normally. As shown in the following figure. 

 

Figure 4.5 Square Waveform Signal 

⚫ Check CH2 channels using the same method. If the square wave waveform 

displayed in the time base does not match the figure above, you can follow 

the instructions in the section on Probe Compensation. 

Warning: 

To avoid electric shock when using the probe, please make sure that the  

insulated wire of the probe is in good condition. Do not touch the  

metallic part of the probe when the probe is connected to high voltage  

source. 

Tip: 

The probe compensation signal can only be used for probe compensation  

adjustment and cannot be used for calibration. 

5. Probe Compensation 

When connecting the probe to any input channel for the first time, this adjustment is 

required to match the probe with the input channel. Uncompensated or offset probes 

can lead to measurement errors or errors. 

⚫ Perform the first four steps of the previous section on "Function Check". 



  Quick start 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               DSO2D20 User manual                                                              

15 

⚫ Compare the waveform with the figure below. 

 

Figure 4.6 Probe Compensation 

⚫ If necessary, use a non-metallic screwdriver to adjust the variable 

capacitance on the probe until the waveform displayed on the screen is 

"Perfectly compensated" as shown in the figure above. If necessary, repeat 

this step. The adjustment method is shown in the following figure. 

 

Figure 4.7 Adjusting capacitance 
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4.4 Front Panel Overview                                 

 

Figure 4.8 Front Panel 

Table 4.1 Front Panel Description 

No. Description 

1 Power Key 

2 Bracket 

3 USB HOST Interface 

4 Menu Selection Key 

5 Vertical Control System, Waveform Control System 

6 Analog Channel Input 

7 Horizontal Control System 

8 
Signal Source Output (limited to models with signal source)/ 

External Trigger Input Channel 

9 Probe Compensation Signal Output Terminal/Ground Terminal 

10 Signal Source (limited to models with signal source) 

11 Trigger Control System 

12 Quick Keys for Operating Mode 



  Quick start 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               DSO2D20 User manual                                                              

17 

13 Menu Function Buttons 

14 Function Shortcut Keys 

15 Multi Functional Knob 

16 Display 

4.5 Front Panel Function Overview                        

1. Horizontal: 

 

⚫ : 

Horizontal time base knob. Rotate this knob to modify the horizontal time 

base. Clockwise rotation reduces the time base, counterclockwise rotation 

increases the time base. During the modification process, the waveforms of 

all channels are expanded or compressed for display, while the time base 

information above the screen changes in real-time. Pressing this knob can 

quickly switch the horizontal time base adjustment mode to "coarse 

adjustment" or "fine adjustment". 

⚫ : 

Horizontal displacement knob. Rotate this knob to modify the horizontal 

displacement (i.e. trigger displacement). When turning the knob, the trigger 

point moves left and right relative to the center of the screen. During the 

modification process, the waveforms of all channels move left and right, while 

the horizontal displacement information above the screen changes in real-

time. Pressing this knob can quickly reset the horizontal displacement (or 
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delay the scanning displacement). 

2. Vertical: 

 

⚫ CH1 MENU and CH2 MENU analog input channel switches: 

Two channels are labeled with different colors, and the color of the waveform 

corresponds to the color of the channel. 

⚫ Channel vertical offset knob: 

Rotate this knob to modify the vertical offset of the current channel waveform. 

Rotate clockwise to increase the offset, and counterclockwise to decrease 

the offset. During the modification process, the waveform will move up and 

down, and the offset information in the corresponding status labels will 

change in real-time. Press this knob to quickly reset the vertical offset to zero. 

⚫ Channel vertical gear knob: 

Modify the vertical gear of the current channel. Rotate clockwise to decrease 

the gear, and counterclockwise to increase the gear. During the modification 

process, the waveform display amplitude will increase or decrease, and the 

corresponding gear information in the status label will change in real time. 

Press this knob to quickly switch the vertical gear adjustment mode to 

"coarse adjustment" or "fine adjustment". 

⚫ MATH MENU: 

                     Mathematical operation keys. Press this key to open the mathematical 

operation function menu, where you can perform A+B, A-B, A × B, A/B, and 

FFT operations. 

3. Wave Gen: 
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⚫ WAVE GEN: 

Press the WAVE GEN button to open the signal generator channel. 

⚫ BURST: 

Burst button. 

4. TRIGGER: 

 

⚫ Trigger knob: 

Modify the trigger level or threshold level. Clockwise rotation increases the 

level, counterclockwise rotation decreases the level. During the modification 

process, the trigger level moves up and down, and the trigger level/threshold 

level value in the upper right corner of the screen changes in real-time. 

Pressing this knob can quickly set the trigger level value to 50% of the 

waveform peak to peak value. 

⚫ TRIG MENU: 

Press the button to open the trigger operation menu. 

⚫ FORCE TRIG: 

Pressing this button will force the oscilloscope to generate a trigger signal. 

5. Quick keys for operating mode: 
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⚫ AUTO SET: 

Press this key to enable the automatic waveform setting function. The 

oscilloscope will automatically adjust the vertical gear, horizontal time base, 

and trigger mode based on the input signal to achieve the best waveform 

display state. 

⚫ SINGLE SEQ: 

Press this key to set the triggering mode of the oscilloscope to single shot. 

⚫ RUN/STOP: 

Press this key to set the operating status of the oscilloscope to "Run" or 

"Stop". In the RUN state, the green backlight of this key lights up; In the STOP 

state, the red backlight of this key lights up. 

6. Menu function buttons: 

 

⚫ SAVE/RECALL: 

This key can perform the function of saving and retrieving. 

⚫ MEASURE: 

Press this key to enter the measurement settings menu. 

⚫ ACQUIRE: 

Press this key to enter the sampling settings menu. The oscilloscope's time 

base mode, acquisition method, and storage depth can be set. 

⚫ UTILITY: 

Press this key to enter the system function settings menu. Set system related 

functions or parameters, such as sound and language. In addition, it also 

supports advanced features such as testing and self calibration. 
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⚫ CURSOR: 

Press this key to enter the cursor measurement menu. The oscilloscope 

provides two cursor modes: manual and tracking. 

⚫ DISPLAY: 

Press this key to enter the display settings menu. The display type, afterglow 

time, and waveform brightness of the waveform can be set. 

7. Function shortcut keys: 

 

⚫ DEFAULT SETUP: 

Press this button to restore the oscilloscope to its factory default settings. 

⚫ HELP: 

Help provides instructions for the various function buttons and corresponding 

menu keys on the front panel. 

⚫ SAVE TO USB: 

Save the screenshot to a USB drive. 

⚫ DECODE: 

Decoding key. Press this key to open the decoding settings menu. 

8. Multi functional knob: 

 

Modify setting parameters by rotating the knob. 
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4.6 Rear Panel Overview                                  

 

Figure 4.9 Rear Panel 

Table 4.2 Rear Panel Description 

No. Description 

1 USB DEVICE 

2 Power Socket 

3 Handle 

4.7 Rear Panel Overview                                   

1. USB DEVICE: 

This interface is used to connect the oscilloscope to a computer, and users can 

send SCPI commands or customize programming to control the oscilloscope 

through the upper computer software. 

2. Power Socket: 

Power input terminal. Please connect the oscilloscope to the power supply using 

the power cord provided in the attachment. 

3. Handle: 

Users can pull up the handle vertically for easy access to the oscilloscope; When 

not in use, simply press down on the handle. 
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4.8 User Interface                                         

 

Figure 4.10 User Interface 

1. Hantek logo: 

Representing the Hantek trademark. 

2. Running status: 

The operating status of the oscilloscope includes READY, TD, STOP, and AUTO. 

3. Horizontal time base: 

Represents the length of time represented by each grid on the horizontal axis of 

the screen. The horizontal knob can be used to modify this parameter. 

4. Sampling rate: 

Display the current sampling rate of the analog channel. The sampling rate will 

change with the variation of the horizontal time base. 

5. Storage depth: 

Display the current storage depth of the simulated channel. The storage depth will 

change with the variation of the horizontal time base. 

6. Horizontal displacement: 
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Adjust parameters through the horizontal knob to display specific horizontal 

position values. 

7. Trigger level: 

Display the current trigger level of the analog channel. 

8. Operation menu: 

Press the menu button in the key area to open the corresponding menu. 

9. USB: 

If the icon is lit or activated, it indicates that the USB drive is connected. 

10. Signal generator: 

Display the open status of the signal generator. 

11. Message box: 

Display prompt message. 

12. CH2 status label: 

Display the status of CH2. Display the vertical gear and offset information of CH2. 

Display current channel settings: channel coupling and bandwidth limitations. 

13. CH1 status label: 

Display the status of CH1. Display the vertical gear and offset information of CH1. 

Display current channel settings: channel coupling and bandwidth limitations. 

14. Simulate channel labels/waveforms: 

Different channels are labeled with different colors, and the channel labels and 

waveform colors are consistent. 

4.9 Help System                                      

To Use the Built-in Help System 

The help system of this oscilloscope provides instructions for various function buttons 

on the front panel and corresponding menu keys. The operation steps are: 

⚫ Click the  button in the button area to enter the help module; 

⚫ Press other keys to obtain help information; 

⚫ Press the  button again to exit the help module. 

For example: 

After clicking the [Help] button, click the [UTILITY] button again, and the explanation 

menu for [UTILITY] will pop up on the screen. 
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5 To Set the Vertical System              
This series of oscilloscopes provides 2 input channels CH1-CH2, each with an 

independent vertical control system. The control systems for two channels are the 

same, and this chapter mainly introduces various setting methods for CH1. Please read 

this chapter carefully to understand the vertical system settings, functions, and 

operations of the tablet oscilloscope. 

Contents in this chapter: 

⚫ To Enable or Disable the Analog Channel 

⚫ To Adjust the Vertical Scale 

⚫ To Adjust the Vertical Offset 

⚫ Channel Coupling 

⚫ Bandwidth Limit 

⚫ Input Impedance 

⚫ Probe Ratio 

⚫ Waveform Invert 

⚫ Fine tuning 
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5.1 To Enable or Disable the Analog Channel              

1. Enable analog channel 

For example, after connecting a signal to the CH1 channel, the channel can be opened 

in the following way. 

⚫ Press the [CH1] button to open the channel, and the light on this button will turn 

on. 

If CH1 is already open and currently selected, the label will be as shown in the following 

figure. 

 

The information displayed in the channel status label is related to the current channel 

settings (independent of the channel's on/off status). 

2. Disable analog channel 

There are several methods to close the simulation channel: 

⚫ If CH1 channel is already open and currently selected, press [CH1] once to close 

CH1 channel. 

⚫ If the CH1 channel is already open but not selected, press [CH1] once to make 

CH1 selected, and then press the CH1 button again to close the CH1 channel. 

5.2 To Adjust the Vertical Scale                            

Vertical gear refers to the voltage value represented by each grid in the vertical 

direction of the display screen, usually expressed as V/div. When adjusting the vertical 

gear, the waveform display amplitude will increase or decrease, and the gear 

information in the channel status label will also change in real-time. 

 

The probe ratio for vertical gear and channel settings is related to the input impedance. 

By default, the probe ratio is 1X and the input impedance is 1M Ω. The vertical gear 

range is 500uV/div~10V/div. 

When CH1 channel is open, the vertical gear can be adjusted through the following 

methods: 

⚫ Rotate the knob corresponding to CH1 to adjust the vertical gear within the 

adjustable range. Rotate clockwise to decrease the gear and counterclockwise to 

increase the gear. 
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5.3 To Adjust the Vertical Offset                           

Vertical offset refers to the deviation of the zero point position of the channel signal of 

the waveform in the vertical direction relative to the center of the screen. The unit is 

consistent with the currently selected amplitude unit. When adjusting the vertical offset, 

the waveform of the corresponding channel moves up and down. 

Adjust vertical offset: 

⚫ Rotate the offset knob in the button area to adjust the vertical offset. 

5.4 Channel Coupling                                     

Setting the coupling method can filter out unwanted signals. Open the channel vertical 

menu and click on the coupling menu to select the coupling type. As shown in the 

following figure. 

⚫ When the coupling mode is "DC": both the DC and AC components contained in 

the measured signal can pass through.    

⚫ When the coupling mode is "AC": the DC component contained in the measured 

signal is blocked.    

⚫ When the coupling method is "grounded": both the DC and AC components 

contained in the measured signal are blocked. 

After setting the coupling method, the current coupling method will be displayed at the 

channel label. 

Tips: 

When the input impedance is selected as 50 ohms, the coupling mode of the channel 

can only be set to DC and cannot be changed. 

5.5 Bandwidth Limit                                       

This oscilloscope supports bandwidth limitation function. Setting bandwidth limits can 

reduce noise in the displayed waveform. 

⚫ When bandwidth limitation is turned off, the high-frequency components contained 

in the measured signal can pass through.    

⚫ If the bandwidth limit is turned on and restricted to 20MHz, high-frequency 

components greater than 20MHz contained in the measured signal will be 

attenuated. 

Click to open [CH1], then click on the BW menu and select the bandwidth limit. You can 

choose to turn off, 20M, 100M, 200M, 350M, and default to off. After opening the 

bandwidth limit, the BW flag is displayed at the channel label. 

Tips: 
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Bandwidth limitation reduces noise while also attenuating or eliminating high-frequency 

components in the signal. 

5.6 Input Impedance                                      

This oscilloscope provides two input impedance modes: 1M Ω and 50 Ω to reduce the 

circuit load caused by the interaction between the oscilloscope and the circuit under 

test. 

Open [CH1], click on the Impedance menu tab, and select an input impedance of 1M Ω 

or 50 Ω. 

⚫ 1M Ω: At this point, the input impedance of the oscilloscope is very high, and the 

current flowing into the oscilloscope from the tested circuit can be ignored. 

⚫ 50 Ω: Match the oscilloscope with a device with an output impedance of 50 Ω. 

5.7 Probe Ratio                                           

Open [CH1], then click on the Attenuation to set the probe. 

The oscilloscope allows users to manually set the probe attenuation ratio, and users 

must set the probe ratio correctly to obtain accurate measurement results. The default 

probe ratio is 1X, and the probe range is 0.01X-1000X. 

To match the actual attenuation ratio of the probe, it is necessary to adjust the channel 

attenuation ratio accordingly under the channel menu. Whenever the attenuation ratio 

of the probe changes, it is necessary to set the corresponding attenuation ratio in the 

channel menu to ensure the correctness of the waveform amplitude and measurement 

results displayed on the oscilloscope. 

Table 5.1 Probe Ratio 

Menu 
Attenuation Ratio(display amplitude of the 

signal: actual amplitude of the signal) 

1X 1:1 

10X 10:1 

50X 50:1 

100X 100:1 

500X 500:1 

1000X 1000:1 
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5.8 Waveform Invert                                       

Open [CH1], click on the inverting menu, select the inverting switch flag to turn it on or 

off, and the flag will light up to turn on the waveform inverting function. The default is to 

turn off inverting. 

When the waveform inversion is turned off, the waveform is displayed normally; When 

the waveform inversion is turned on, the waveform voltage value is inverted. Opening 

waveform inversion will also change the results of mathematical operations, waveform 

measurement, and other operations. 

 

Figure 5.1 "Invert" Off 
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Figure 5.2 "Invert" On 

5.9 Fine tuning                                            

Open [CH1], click on the Fine adjustment menu, and the label will light up to indicate 

fine adjustment. The default setting is coarse adjustment. 

⚫ Fine adjustment: The vertical gear will be adjusted within a small range, changing 

the vertical resolution to facilitate the observation of waveform details. 

⚫ Coarse adjustment: Set the vertical gear in steps of 1 to 2 to 5. 
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6 To Set the Horizontal System           
This chapter contains detailed information about the oscilloscope horizontal system. We 

suggest that you read carefully to understand the setting functions and operation of the 

oscilloscope horizontal system. 

Horizontal adjustment can be achieved through the following methods: 

⚫ Adjust the time base knob and displacement knob in the key area to adjust the 

horizontal setting. 

 

This chapter includes: 

⚫ To Adjust the Horizontal Position 

⚫ To Adjust the Horizontal Time Base 

⚫ Pan or zoom single acquisition or stopped acquisition 

⚫ Delayed Sweep 

⚫ Horizontal Mode 
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6.1 To Adjust the Horizontal Position                     

Horizontal displacement refers to the displacement of the waveform trigger points of all 

channels in the horizontal direction relative to the center of the screen. When the 

waveform trigger point is located on the left (right) side of the screen center, the 

horizontal displacement is positive (negative).      

When changing the horizontal displacement, the waveform trigger points and displayed 

waveforms of all channels move left and right; The horizontal displacement information 

above the screen changes in real-time. 

⚫ Adjust the horizontal displacement by rotating the horizontal displacement knob. 

 

6.2 To Adjust the Horizontal Time Base                    

The horizontal time base is the time value represented by each grid in the horizontal 

direction of the display screen, generally expressed as s/div. The adjustable range of 

the horizontal time base is 2ns/div~100s/div. The default value is 1 us/div. 

Changing the horizontal time base will display real-time information on the screen. 

The horizontal time base can be adjusted by the following methods: 

⚫ Adjust the horizontal time base by rotating the horizontal time base knob. 

6.3 Pan or zoom single acquisition or stopped 

acquisition  

After the oscilloscope stops, the stopped display may contain several collected data 

with useful information, but only the last collected data can be panned and scaled. Pan 

and zoom the data collected in a single or stopped collection. 

6.4 Delayed Sweep                                        

Delay scanning is used to horizontally magnify a segment of waveform for viewing 

waveform details. 

Click the button  in the button area, and the screen will be divided into two display 

areas. 
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Figure 6.1 Delayed Sweep Mode 

Waveform before amplification: 

The upper half of the screen is the waveform before amplification, and its horizontal 

time base (known as the main time base) is displayed in the upper left corner of the 

screen. You can move the area left and right by adjusting the horizontal displacement, 

or expand or decrease the area by adjusting the base gear when horizontal. 

Amplified waveform: 

The lower part of the screen is a horizontally extended delayed scanning waveform, 

with its horizontal time base (referred to as the delayed scanning time base) displayed 

on the screen. Delayed scanning time base improves resolution compared to the main 

time base. 

Tip: 

The delay scanning time base should be less than or equal to the main time base. 

6.5 Horizontal Mode                                   

Click the button [HORIZ MENU] to set the horizontal mode, and select YT, XY, and 

scroll. 

6.5.1 YT Mode                                            

In this mode, the Y-axis represents the usual voltage and the X-axis represents the 

time. 
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In YT mode, when the horizontal time base is set to 100 ms/div or slower, the 

oscilloscope enters scanning mode. In this mode, the oscilloscope first collects data to 

the left of the trigger point, then waits for the trigger condition to occur, and continues to 

complete the waveform to the right of the trigger point after the trigger condition occurs, 

while displaying the currently collected waveform data. 

Tips: 

Scanning mode observation signal frequency is low, it is recommended to set the 

"channel coupling" mode to "DC". 

6.5.2 XY Mode                                            

This series of oscilloscopes supports the XY mode waveform display window "XY 

window", in which both the X and Y axes represent voltage levels. 

Phase difference measurement: 

The Lissajous method can conveniently measure the phase difference between two 

signals of the same frequency. The following diagram shows the principle of measuring 

phase difference. 

 

Figure 6.2 Delayed Sweep Mode 

According to or , where θ is the phase difference angle between 

channels, the definitions of A, B, C, and D are shown in the above figure. Therefore, the 

phase difference angle can be obtained, that is:  

If the main axis of the ellipse is within quadrants I and III, the obtained phase difference 

angle should be within quadrants I and IV, that is, within (0 to π/2) or (3 π/2 to 2 π). If 

the main axis of the ellipse is within quadrants II and IV, the obtained phase difference 

angle should be within quadrants II and III, that is, within (π/2 to π) or (π to 3 π/2). The 
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X-Y function can be used to test the phase changes generated by a signal passing 

through a circuit network. Connect the oscilloscope to the circuit and monitor the input 

and output signals of the circuit. 

Tips: 

In general, longer sampling waveforms can result in better display effects, but due to 

the limitation of storage depth, longer waveform length means that the sampling rate 

needs to be reduced. Therefore, in this measurement process, reducing the sampling 

rate appropriately can obtain a better display effect of Li Shayu graphics. 

Using the Lissajous method 

1 Connect a sine signal to CH1, and then connect a sine signal with the same 

frequency, amplitude, and phase difference of 90 ° to CH2. 

2 Click on [AUTO Scale], select XY mode, and rotate the knob to adjust the 

sampling rate appropriately to obtain a better Li Shayu graph for better observation 

and measurement. 

3 Adjust the vertical knobs corresponding to channels CH1 and CH2 to make the 

signal easier to observe. At this point, the circle shown in the following figure 

should be obtained. 

 

Figure 6.3 Delayed Sweep Mode 

4 Observing the measurement results in the above figure and based on the phase 

difference measurement principle diagram (Figure 6.3), it can be concluded that 

A/B (C/D)=1, which means the phase difference angle between the input signals of 

the two channels is =  arcsin1=90 °. 

6.5.3 Roll Mode                                           

Click on [HORIZ MENU] -> Mode -> Roll, select the scroll mode, and in this mode, the 

waveform will scroll from right to left to refresh the display. The adjustment range of the 
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horizontal gear is 100ms to 100s. 
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7 To Set the Sample System              
Click on the button area [Acquire] to enter the settings menu. 

This chapter includes: 

⚫ Acquire Type 

⚫ Acquire Mode 

⚫ Memory Depth 
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7.1 Acquire Type                                       

Open [Acquire], click on the Acquire type menu, and select the collection type: real-

time sampling, equivalent sampling. 

⚫ Real time sampling: Real time digital technology is used to collect waveforms. 

⚫ Equivalent sampling: Reconstruct waveforms using equivalent sampling 

techniques. 

7.2 Acquire Mode                                     

Open [Acquire], click on the Acquire Mode menu, select Normal, Average, Peak, High 

Resolution, and the default acquisition method is Normal. 

7.2.1 Normal Mode                                        

In this mode, the oscilloscope samples the signal at equal time intervals to reconstruct 

the waveform. For most waveforms, using this mode can produce the best display 

effect. 

7.2.2 Average Mode                                        

In this mode, the oscilloscope averages multiple sampled waveforms to reduce random 

noise on the input signal and improve vertical resolution. The higher the average 

frequency, the smaller the noise and the higher the vertical resolution, but the response 

of the displayed waveform to waveform changes is also slower. 

After selecting the Average mode, click the "Average Times" button and continuously 

press the menu button to set it to 4, 8, 16, 32, 64, 128. The default is 4. 
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Figure 7.1 Delayed Sweep Mode 

 

Figure 7.2 Delayed Sweep Mode 

7.2.3 Peak Mode                                          

In this mode, the oscilloscope collects the maximum and minimum values of the signal 

within the sampling interval to obtain the envelope of the signal or narrow pulses that 

may be lost. Using this mode can avoid signal aliasing, but the displayed noise is 

relatively high. 

In this mode, the oscilloscope can display all pulses at least as wide as the sampling 

period. 



To Set the Sample System 

  EN 

DSO2D20 User manual                                              Copyright © Qingdao Hantek Electronic Co., LTD 

40 

7.2.4 High Resolution                                         

This mode adopts a supersampling technique that averages adjacent points of the 

sampled waveform, reducing random noise on the input signal and producing a 

smoother waveform on the screen. Usually used when the sampling rate of a digital 

converter is higher than the storage rate of the acquisition memory. 

Note: 

The averaging method used in "average" and "high resolution" modes is different, with 

the former being "multiple sample averaging" and the latter being "single sample 

averaging". 

7.3 Memory Depth                                        

Storage depth refers to the number of waveform points that an oscilloscope can store in 

a single trigger acquisition. It reflects the storage capacity of the acquisition memory. 

 

Figure 7.3 Memory Depth 

The following equation shows the relations among memory depth, sample rate, and  

horizontal time base scale: 

MDepth =  SRate * TScale * HDivs  

⚫ MDepth ——indicates the memory depth. The unit is pts. 

⚫ SRate——indicates the sample rate. The unit is Sa/s. 

⚫ TScale ——indicates the horizontal time base scale. The unit is s/div. 

⚫ HDivs ——indicates the number of grids in the horizontal direction. The unit is div. 

Therefore, under the same horizontal time base scale, a higher memory depth can  

ensure a higher sample rate. 

Open [Acquire], click on the Mem Depth menu, and select the storage depth. 

⚫ Single channel mode: Storage depth options: 4K, 40K, 80K. 
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⚫ Full channel mode: Storage depth options: 4K, 40K. 
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8 To Trigger the Oscilloscope             
The so-called triggering refers to setting certain triggering conditions according to 

requirements. When a certain waveform in the waveform flow meets this condition, the 

oscilloscope immediately captures the waveform and its adjacent parts, and displays 

them on the screen. The trigger determines when the oscilloscope starts acquiring data 

and displaying waveforms. Once the trigger is set correctly, the oscilloscope can 

convert unstable displays or blank screens into meaningful waveforms. Here are some 

basic concepts of triggers. 

You can enter the trigger menu by: 

⚫ Click on the button area [TRIG MENU] to enter the trigger menu. 

This chapter includes: 

⚫ Trigger LEVEL 

⚫ Trigger Source 

⚫ Trigger Mode 

⚫ Trigger Type 
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8.1 Trigger LEVEL                                       

The trigger level is the signal voltage corresponding to the set trigger point, which is 

related to the type of trigger signal source. 

⚫ The trigger flag and trigger level line move up and down as the trigger level 

changes. The trigger flag and channel color remain consistent. When changing the 

trigger level, a trigger level line will temporarily appear on the screen to tell you the 

position of the level (the specific value of the trigger level is displayed in the trigger 

menu label at the top right of the screen). After about 2 seconds of stopping 

modifying the trigger level, the trigger level line disappears. 

⚫ For slope triggering, under amplitude triggering, and over amplitude triggering, it is 

necessary to set the triggering levels: the level values of level A and level B. 

Through the Level Select menu in the [TRIG MENU] menu, select the current 

adjustable levels as level V1, level V2, and level V1V2. 

8.2 Trigger Source                                      

Click on the button area [TRIG MENU] to enter the Source menu. The available data 

sources include: CH1~CH2, External, Line. 

Analog channel: The input signals of analog channels CH1-CH2 can all be used as 

trigger sources, and only by selecting the channel with already connected signals as 

the trigger source can stable triggering be obtained. 

External source: External trigger input, triggered on the [EXT TRIG] terminal of the 

oscilloscope front panel. The external trigger signal must be a 0-3.3V CMOS waveform. 

Line: Triggered at 50% level of the AC power signal. 

Tips: 

To avoid damaging this product, do not input signals exceeding 3.3 volts to the [EXT 

TRIG/GEN OUT] connector. 

8.3 Trigger Mode                                        

The following is a schematic diagram of the acquisition memory. To facilitate the 

understanding of triggering events, the collection memory can be divided into pre 

triggered buffer and post triggered buffer. 
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Figure 8.1 Schematic Diagram of the Acquisition Memory 

After starting operation, the oscilloscope will first fill the pre triggered buffer. After filling, 

the oscilloscope will start searching and triggering; During the search period, the 

sampled data will continue to be transmitted to the pre triggered buffer (new data will 

continuously overwrite existing data). After searching for a trigger, the pre trigger buffer 

will contain the events that occurred before the trigger. Then, the oscilloscope will fill the 

trigger buffer and display the data in the acquisition memory. If the collection is initiated 

through the [Run/Stop] button, the process will be repeated; If the acquisition is 

initiated through the [SINGLR SEQ] key, it will stop after completing a single acquisition 

(the current displayed waveform can be panned and scaled). 

The oscilloscope trigger mode provides Normal, Auto, and Single trigger. The trigger 

mode defaults to automatic mode. 

⚫ Normal mode: Only when the oscilloscope has a valid trigger will the displayed 

waveform be updated. Before replacing the original waveform with a new 

waveform, the oscilloscope will display the original waveform. Use the "normal" 

mode only when you want to view the waveform that is effectively triggered. When 

using this mode, the oscilloscope only displays the waveform after the first trigger. 

⚫ Auto mode: can freely run collection without effective triggering. This mode allows 

for untriggered scanning waveforms to occur at a time base setting of 100 

milliseconds/grid or slower. When the oscilloscope detects a valid triggering 

condition, complete a triggered acquisition. When the oscilloscope detects that 

there are no valid triggering conditions, complete a non triggering acquisition. 

⚫ Single mode: Only when the oscilloscope has a valid trigger can the collection end 

and enter the stop state. 

⚫ Forced trigger: In both normal and single trigger modes, pressing the forced trigger 

button in the trigger menu can forcibly generate a trigger signal. 

When a signal characteristic is not understood, the oscilloscope should be set to 

"automatic" mode, which can ensure that the oscilloscope also displays waveforms 

when other trigger settings are incorrect. Although the waveform may not be stable, it 

can provide us with intuitive judgment for further adjusting the oscilloscope. 
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When we set specific triggering conditions for a particular signal, especially when the 

time interval to meet the triggering conditions is relatively long, we need to set the 

triggering mode to "normal" to prevent the oscilloscope from automatically triggering. 

8.4 Trigger Type                                        

This series of machines has multiple triggering functions. Open the [TRIG MENU], click 

on the Type menu, and select the trigger type. 

⚫ Edge Trigger 

⚫ Pulse Trigger 

⚫ Video Trigger 

⚫ Slope Trigger 

⚫ Overtime Trigger 

⚫ Window Trigger 

⚫ Pattern Trigger 

⚫ Interval Trigger 

⚫ Under Amp Trigger 

⚫ UART Trigger 

⚫ LIN Trigger 

⚫ CAN Trigger 

⚫ SPI Trigger 

⚫ I2C Trigger 

8.4.1 Edge Trigger                                             

Edge triggering is triggered at the trigger threshold specified by the input signal for the 

edge. 

 

Figure 8.2 Rising/Falling 

Click on [TRIG MENU] in the button area to open the trigger menu. 
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1. Type: 

Click on the Type menu tab and select "Edge Trigger" to set the trigger. 

After selecting the trigger type, the current trigger setting information (including trigger 

source and trigger level) will be displayed at the top of the screen, which will change 

with the change of trigger settings. 

2. Source: 

Click on the Source menu tab to select CH1, CH2, external, and Line. 

3. Slope Type: 

Click on the Slope menu label, and the edge types that can be selected include: rising 

edge, falling edge, or any edge. 

⚫ Rising: Set the signal's rising edge to trigger. 

⚫ Falling: Set the signal falling edge trigger. 

⚫ Either: Set the signal to trigger the rising or falling edge. 

4. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

5. 50%: 
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Click on the 50% menu tab and set the trigger level to the vertical midpoint of the peak 

to peak value of the trigger signal. The trigger level value is displayed in the upper right 

corner of the screen. 

6. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

Tips: 

The automatic setting button will set the trigger type to edge trigger and the edge type 

to rising edge. 

8.4.2 Pulse Trigger                                           

Pulse width trigger sets the oscilloscope to trigger on a specified width of positive or 

negative pulses. You can set the trigger source, polarity (positive pulse width, negative 

pulse width), limiting conditions, and pulse width in this menu. 

 

Figure 8.3 Positive Pulse Width/Negative Pulse Width 

Click on [TRIG MENU] in the button area to open the trigger menu. 
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1. Type: 

Click on the Type menu label and select "Pulse" to set the trigger.After selecting the 

trigger type, the current trigger setting information (including trigger type, trigger source, 

and trigger level) will be displayed at the top of the screen, which changes with the 

trigger setting. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 

3. Polarity: 

Click on the Polarity menu tab to select either positive or negative polarity. 

⚫ Positive polarity: triggered when the positive polarity pulse width of the signal is 

set. 

⚫ Negative polarity: triggered when the signal negative polarity pulse width is set. 

4. When: 

Click on the When menu tab and select Trigger Condition. 

⚫ =(Equal to time value): Only when the positive or negative pulse width of the input 

signal is equal to the set pulse width can it be triggered. 

For example, for a positive pulse, if t (actual pulse width) is set to 200ns, the 

waveform is triggered. 

 

⚫ != (Not equal to time value): Only when the positive or negative pulse width of the 



  To Trigger the Oscilloscope 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               DSO2D20 User manual                                                              

49 

input signal is not equal to the set pulse width can it be triggered. 

 

⚫ > (greater than the time value): Only when the positive or negative pulse width of 

the input signal is greater than the set pulse width can it be triggered. 

For example, for a positive pulse, if t (actual pulse width) is set to>100ns, the 

waveform is triggered. 

 

⚫ <(less than the time value): Only when the positive or negative pulse width of the 

input signal is less than the set pulse width can it be triggered. 

For example, for a positive pulse, if t (actual pulse width) is set to<100ns, the 

waveform is triggered. 

 

5. Width: 

Click on the Width menu tab and select the multi-functional knob V0 to set the trigger 

release or the pop-up numeric keyboard to directly set the trigger release. 

6. 50%: 

Click on the 50% menu tab and set the trigger level to the vertical midpoint of the peak 

to peak value of the trigger signal. The trigger level value is displayed in the upper right 

corner of the screen. 

7. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

8. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 
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8.4.3 Video Trigger                                           

Video triggering can be used to capture complex waveforms of most standard analog 

video signals and high-definition video signals. The trigger circuit can detect the vertical 

and horizontal intervals of the waveform and generate a trigger based on the selected 

video trigger setting. This series of oscilloscopes supports NTSC (National Television 

Standards Committee) and PAL. 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu tab, select "Video Trigger", and set the trigger. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 

3. Polarity: 

Click on the Polarity menu tab to select either positive or negative polarity. 

⚫ Positive polarity: triggered when the positive polarity pulse width of the signal is 

set. 

⚫ Negative polarity: triggered when the signal negative polarity pulse width is set. 

4. Standard: 

Click on the Standard menu tab and select the desired video standard. The video 

standards supported by this series of oscilloscopes include NTSC, PAL/SCEAM. 
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Table 8.1 Video Standard 

Video Standard Frame Frequency  Scan Type 
TV Scan 

Line 

NTSC 30 Interlaced Scan 525 

PAL 25 Interlaced Scan 625 

5. Sync: 

Click on the Sync menu tab and select the desired field or line (ScanLine, LineNum, 

OddField, EvenField, AllFields) to trigger the signal. 

⚫ ScanLine: displays a complete line, including a portion of the previous and next 

lines. The oscilloscope is triggered at any line. 

⚫ LineNum: Display a complete line, including a portion of the previous and next 

lines. Select a specified number of rows for the oscilloscope to trigger based on 

user selection. 

⚫ OddField: displays multiple fields and the oscilloscope only triggers on odd fields. 

⚫ EvenField: display multiple fields and the oscilloscope only triggers on even 

numbered fields. 

⚫ AllFields: Display multiple fields and trigger the oscilloscope on any field. 

6. Line: 

Click on the Line number menu tab and set the line number in the field to be triggered. 

When selecting the synchronization method as the number of lines, you can specify the 

number of lines. The range of line count settings is related to the currently selected 

video standard, with settings ranging from 1 to 525 (NTSC) and 1 to 625 (PAL/SECAM). 

7. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

8. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 
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8.4.4 Slope Trigger                                             

Slope triggering sets the positive or negative slope triggering of the oscilloscope from 

one level to another within a specified time. 

As shown in the figure below, we define the time difference between the two points (A 

and B) where the high and low trigger levels intersect with the rising (falling) edge of the 

waveform as the positive (negative) slope time. 

 

Figure 8.4 Positive Slope Time/Negative Slope Time 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu tab and select "Slope Trigger" to set the trigger. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 

3. Slope Type: 
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Click on the Slope menu tab to select rising and falling edges. 

⚫ Rising: Set the signal slope condition to trigger with a positive slope. 

⚫ Falling: Set the signal slope condition to trigger with a negative slope. 

4. Level: 

Click on the Level menu tab, continuously press the level tab, and select the set level 

1, level 2, or level 12. 

5. When: 

Click on the When menu tab and select Trigger Condition. 

⚫ <(less than time value): Only when the positive or negative slope time of the input 

signal is less than the set time value can it be triggered. 

⚫ >(Greater than time value): It can only be triggered when the positive or negative 

slope time of the input signal is greater than the set time value. 

⚫ != (Not equal to time value): When the positive or negative slope time of the input 

signal is not equal to the set time value. 

⚫ =(Equal to time value): When the positive or negative slope time of the input signal 

is equal to the set time value. 

6. Time: 

Click on the Time menu tab and set the trigger release by selecting the multi-functional 

knob V0 or directly set it on the pop-up numeric keyboard. 

7. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

8. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.5 Overtime Trigger                                        

Triggered when the time interval (△T) from the rising edge (or falling edge) of the input 
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signal to the end of the adjacent falling edge (or rising edge) through the triggering level 

is greater than the set timeout time. As shown in the following figure: 

 

Figure 8.5 Overtime Trigger 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu tab, select "Overtime trigger", and set the trigger. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 

3. Slope type: 

Click on the Slope Type menu tab to select Positive and Negative edges. 

⚫ Positive: Start timing by triggering the level on the rising edge of the input signal. 

⚫ Negative: Start timing by triggering the level at the falling edge of the input signal. 
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4. Time: 

Click on the Time menu tab and set the time by rotating the multifunctional knob V0. 

The timeout period can be set within the range of 8ns to 10s. 

5. 50%: 

Click on the 50% menu tab and set the trigger level to the vertical midpoint of the peak 

to peak value of the trigger signal. The trigger level value is displayed in the upper right 

corner of the screen. 

6. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

7. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.6 Window Trigger                                         

Window triggering provides high and low trigger levels. When the input signal passes 

the high or low trigger level, the oscilloscope triggers. 

 

Figure 8.6 Window Trigger 

⚫ If both the high and low levels are within the waveform range, the waveform is 

triggered on the rising or falling edge at the same time. 

⚫ If the high level is within the waveform range and the low level is outside the 

waveform range, the waveform will only trigger on the rising edge. 

⚫ If the high level is outside the waveform range and the low level is within the 

waveform range, the waveform will only trigger on the falling edge. 

Click on [TRIG MENU] in the button area to open the trigger menu. 
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1. Type: 

Click on the Type menu tab, select "Window Trigger", and set the window trigger. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 

3. Level Select: 

After setting the triggering conditions, it is necessary to adjust the triggering level to 

correctly trigger the signal and obtain a stable waveform. 

Select the Level type from the level selection menu tab. 

⚫ Level 1: Only adjust the upper limit of the trigger level, while keeping the lower limit 

of the trigger level unchanged. 

⚫ Level 2: Only adjust the lower limit of the trigger level, while keeping the upper limit 

of the trigger level unchanged. 

⚫ Level 12: Adjust both the upper and lower trigger levels simultaneously, keeping 

the trigger level difference (i.e. the difference between the upper and lower trigger 

levels) unchanged. 

4. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 
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is displayed. 

5. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.7 Pattern Trigger                                       

Identify triggering conditions by searching for specified code patterns. The code pattern 

is a combination of channel logic 'and', and each channel can be set as H (high), L 

(low), X (ignored). You can also specify one channel in the pattern as the rising edge or 

falling edge (only one edge can be specified). After specifying the edge, if the code 

patterns of other channels are judged as "true" (i.e. the actual code pattern is consistent 

with the preset code pattern), the oscilloscope will trigger on the specified edge. If no 

edge is specified, the oscilloscope will trigger on the last edge that makes the code 

pattern "true". If all channel codes are set to 'ignore', the oscilloscope will not trigger. 

 

Figure 8.7 Window Trigger 

Click on [TRIG MENU] in the button area to open the trigger menu. 
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1. Type: 

Click on the Type menu tab, select "Pattern trigger", and set the code trigger. 

2. Logic: 

Click on the Logic menu tab and set the logic to AND, OR, or. 

3. Pattern: 

Click on the Pattern menu tab and select: x, 1, 0, Rising, Falling, or Either. 

⚫ 1: Set the channel code to "H", which means the level is higher than the trigger 

level of the channel.   

⚫ 0: Set the channel code to "L", which means the level is lower than the trigger level 

of the channel.   

⚫ X: Set the channel code type to "X", which means that this channel is not part of 

the code type. When all channels of the code are set to "x", the oscilloscope will 

not trigger.   

⚫ :Set the code pattern of the selected channel as rising edge.   

⚫ :Set the code pattern of the selected channel as a falling edge.   

⚫ :Set the code pattern of the selected channel as rising edge or falling edge. 

4. Level: 

Click on the Level menu tab and select the set level as CH1 or CH2. 

5. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 
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waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

6. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.8 Interval Trigger                                       

Triggered when the interval between two consecutive rising (or falling) edges satisfies 

the set time condition (<,>,!=,=). 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu tab, select "Interval Trigger", and set the trigger. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 

3. Slope: 

Click on the Slope menu tab to select the rising edge and falling edge. 

⚫ Rising edge: Set the signal slope condition to trigger with a positive slope. 
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⚫ Falling edge: Set the signal slope condition to trigger with a negative slope. 

4. When: 

Select the trigger limit condition for under amplitude pulse triggering in the When menu 

tab. 

⚫ >[Greater than the set width value]: Only when the negative or positive pulse width 

is greater than the set width can it be triggered (with a pulse width error of 5%). 

⚫ <[Less than the set width value]: Only when the negative or positive pulse width is 

less than the set width can it be triggered (with a pulse width error of 5%). 

⚫ =[Equal to the set width value]: Only when the negative or positive pulse width is 

equal to the set width can it be triggered (with a pulse width error of 5%). 

⚫ !=  [Not equal to the set width value]: Only when the negative or positive pulse 

width is not equal to the set width can it be triggered (with a pulse width error of 

5%). 

5. Time: 

Click on the Time menu tab and set the trigger release or pop-up numeric keypad 

directly by rotating the multifunctional knob V0. The slope time can be set within the 

range of 8ns to 10s. 

6. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

7. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.9 Under Amp Trigger                                              

Underamplitude triggering is used to trigger a pulse that crosses one trigger level but 

does not cross another trigger level, as shown in the following figure:: 
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负向欠幅

触发点

触发点

触发电平1

触发电平2

正向向欠幅

 

Figure 8.8 Runt Trigger 

⚫ Positive underamplitude: The pulse crosses a low level but not a high level. 

⚫ Negative underamplitude: The pulse crosses a high level but not a low level. 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu tab and select "Under Amp Trigger" to set the underamplitude 

pulse trigger. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 

3. Polarity: 

Select the Polarity of the pulse that can trigger the under amplitude pulse in the polarity 
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menu tab. 

⚫ Positive polarity: triggered on a forward under amplitude pulse. 

⚫ Negative polarity: triggered on a negative under amplitude pulse. 

4. When: 

Select the trigger limit condition for under amplitude pulse triggering in the When menu 

tab. 

⚫ >[Greater than the set width value]: Only when the negative or positive pulse width 

is greater than the set width can it be triggered (with a pulse width error of 5%). 

⚫ <[Less than the set width value]: Only when the negative or positive pulse width is 

less than the set width can it be triggered (with a pulse width error of 5%). 

⚫ =[Equal to the set width value]: Only when the negative or positive pulse width is 

equal to the set width can it be triggered (with a pulse width error of 5%). 

⚫ !=[Not equal to the set width value]: Only when the negative or positive pulse width 

is not equal to the set width can it be triggered (with a pulse width error of 5%). 

5. Width: 

Click on the Width menu tab and set the width value directly by rotating the multi-

functional knob V0 or the pop-up numeric keyboard. 

6. Level: 

Click on the Level menu tab, continuously press the level tab, and select the set level 

1, level 2, or level 12. 

7. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

8. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.10 UART Trigger                                       

UART bus is a serial communication method used for data transmission between 



  To Trigger the Oscilloscope 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               DSO2D20 User manual                                                              

63 

computers or between computers and terminals. 

The UART serial protocol transmits a character as a frame of data, with a frame 

structure consisting of 1 bit start bit, 5-8 bits data bit, 1 bit check bit, and 1-2 bits stop 

bit. The format is shown in the following figure. This series of oscilloscopes can trigger 

when detecting frame start, frame end, data, verification errors, and errors of UART 

signals. 

 

Figure 8.9 Schematic Diagram of UART Protocol 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu tab, select "UART Trigger", and set the UART trigger. 

2. Source: 

Click on the data source menu tab to select CH1 and CH2 data sources. 

3. Idle Level: 

Click on the Idle Level menu tab and select whether the idle level is high or low. 

4. When: 

Click on the When menu tab and select the desired trigger condition. 
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⚫ Start: Triggered at the start position of the frame. 

⚫ Stop: Triggered at the end of the frame position. 

⚫ Spec Data: Triggered in custom data bits. When the data length of the testing 

equipment is 5-8 bits, it can be used. 

◼ Press the condition menu tab and select the equation qualifier. Choose 

specific data values that are equal to (=), not equal to (!=), less than (<), or 

greater than (>).    

◼ Use the Data menu tab to rotate V0 to set the desired data value. The range 

of data values that can be set is 0x00~0xff. Use the data menu in conjunction 

with the condition menu. 

⚫ Parity ERR: Triggered when the data reception is completed and the verification 

result does not match the data set by the user. 

⚫ COM ERR: Triggered when an error frame is detected. 

5. Baud Rate: 

Click on the Baud Rate menu tab and select the preset baud rate from the pop-up sub 

options. Alternatively, click again to pop up the numeric keypad and directly enter the 

set baud rate. 

6. Parity: 

Click on the Parity menu tab, select polarity, and you can choose None, Odd, or Even. 

7. Data Bits: 

Click on the Data Bits menu tab and select the desired data width. The data width 

refers to the number of bits of data per frame. The data width can be selected as 5 bit, 

6 bit, 7 bit, or 8 bit. 

8. Data: 

Click on the Data menu tab and set the data by rotating the multifunctional knob V0. 

Set the data using V0. When the arrow in the upper left corner of the data menu 

displays up and down arrows, rotate V0 to set the value of the current data bit; Press 

V0 again, and the arrow in the upper left corner of the data menu will change to a left or 

right arrow. Rotate V0 to select the data bit that needs to be set.   

: Horizontal arrow, rotate V0 to select a number.    

: Vertical arrow, rotate V0 to set the value of the selected number. 

9. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 
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input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

10. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.11 LIN Trigger                                          

This oscilloscope can be triggered on the synchronous field of LIN signals, as well as 

on designated identifiers, data, or frames. 

The format of the LIN bus data frame is shown in the following figure. 

 

Figure 8.10 Data Frame Format of the LIN Bus 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu label and select "LIN trigger" to set the LIN trigger. 

2. Source: 

Click on the Source menu tab to select CH1 and CH2 data sources. 
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3. Baud Rate: 

Click on the Baud Rate menu tab and select the pre-set baud rate from the pop-up sub 

options. 

If there is no baud rate that matches the tested device, you can choose to customize it. 

Set the baud rate in the custom menu tab. 

4. Idle Level: 

Click on the Idle Level menu tab and select whether the idle level is high or low. 

5. Identifier: 

Click on the Identifier menu tab and rotate V0 to set the identifier. The range is from 

0x00 to 0x3f. 

6. Data: 

Click on the Data Index menu tab, set the range from 0 to 3, and you can set four data 

values. 

When clicking on the Data Mask menu tab and setting it to "ON", the data in that index 

will be ignored when triggered; Set to 'OFF', the data on the data line must be 

consistent with the data in the index in order to trigger. 

Click on the Data menu tab and set the data by rotating the multifunctional knob V0. 

Set the data using V0. When the arrow in the upper left corner of the data menu 

displays up and down arrows, rotate V0 to set the value of the current data bit; Press 

V0 again, and the arrow in the upper left corner of the data menu will change to a left or 

right arrow. Rotate V0 to select the data bit that needs to be set.   

: Horizontal arrow, rotate V0 to select a number.    

: Vertical arrow, rotate V0 to set the value of the selected number. 

7. When: 

Click on the When menu tab to select the desired trigger condition. 

⚫ Interval Field: Triggered by the edge after the end of LIN interval. 

⚫ Sync Field: Triggered upon completion of LIN sync field data reception. 

⚫ ID Field: triggered after receiving data from LINID field. 

⚫ Sync Code Error: Triggered when the LIN synchronization field data reception is 

completed but the synchronization field data is not equal to 0x55. 

⚫ Identifier: Triggered when the LINID field data is received and the ID data is equal 

to the user set ID. 

⚫ ID And Data: LIN data is received normally, and both ID and data are triggered by 

the user's set data. 

8. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 
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⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

9. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.12 CAN Trigger                                          

This oscilloscope can be triggered at the beginning of the CAN signal frame, at a 

specified type of frame (such as remote frame, data frame, etc.), or at a specified type 

of error frame. The format of the CAN bus data frame is shown in the following figure. 

 

Figure 8.11 Data Frame Format of the CAN Bus 

Click on [TRIG MENU] in the button area to open the trigger menu. 
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1. Type: 

Click on the Type menu label and select "CAN trigger" to set the CAN trigger. 

2. Source: 

Click on the Source menu tab and select CH1-CH2. 

3. Baud Rate: 

Click on the Baud Rate menu tab and select the preset rate from the pop-up menu. 

4. Idle Level: 

Click on the Idle Level menu tab and select whether the idle level is high or low. 

5. Identifier: 

Click on the Identifier menu tab and rotate V0 to set the identifier.  

6. Data: 

Click on the Data Index menu tab, set the range from 0 to 3, and you can set four data 

values. 

When clicking on the Data Mask menu tab and setting it to "ON", the data in that index 

will be ignored when triggered; Set to 'OFF', the data on the data line must be 

consistent with the data in the index in order to trigger. 

Click on the Data menu tab and set the data by rotating the multifunctional knob V0. 

Set the data using V0. When the arrow in the upper left corner of the data menu 

displays up and down arrows, rotate V0 to set the value of the current data bit; Press 

V0 again, and the arrow in the upper left corner of the data menu will change to a left or 

right arrow. Rotate V0 to select the data bit that needs to be set.   
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: Horizontal arrow, rotate V0 to select a number.    

: Vertical arrow, rotate V0 to set the value of the selected number. 

7. When: 

Click the When menu button to select the desired trigger condition. 

⚫ Start Bit: Triggered at the beginning of a data frame. 

⚫ Remote Frame ID: Triggered on the remote frame with the specified ID. 

⚫ Data Frame ID: Triggered on the data frame with the specified ID. 

⚫ ID: Triggered on the frame with the specified ID. 

⚫ ID and Data: Triggered on the data frame of the specified ID and the data frame of 

the specified data. After selecting the frame ID and data, click on the definition 

menu tab and select either data or ID. 

⚫ Error Frame: Triggered on the error frame. 

⚫ All Error: Triggered on all errors. 

⚫ Ack Error: Triggered on confirmation error. 

⚫ Overload Frame: Triggered on an overload frame. 

8. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

9. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.13 SPI Trigger                                          

Under the SPI trigger type, when the timeout conditions are met, the oscilloscope 

triggers when it searches for the specified data. SPI trigger is a high-speed, full duplex, 

synchronous communication bus. When using SPI trigger, it is necessary to specify the 

serial clock line (CLK) and serial data line (MISO). 
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Figure 8.12 Sequential Chart of SPI Bus 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu label and select "SPI trigger" to set the SPI trigger.  

2. Source: 

Click on the CLK and MISO menu tabs respectively to select CH1-CH2. 

3. Slope type: 

Click on the Slope menu tab to select the desired clock edge type. 

⚫ Rising: Sampling MISO data at the rising edge of the clock. 

⚫ Falling: Sampling MISO data at the falling edge of the clock. 

4. Level: 

Click on the Level menu tab to set the levels for SCK and MOSI/MISO. 

5. Data Width: 
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Click on the Data Width menu tab to set the number of bits for the serial data string. 

Serial data strings can be specified as 4, 8, 16, 24, or 32 bits long. 

6. Data: 

Click on the Data Mask menu tab, which is a hexadecimal number with 0- block, f - not 

block, and 1- e - block some data. 

Click on the Data menu tab and set the data by rotating the multifunctional knob V0. 

Set the data using V0. When the arrow in the upper left corner of the data menu 

displays up and down arrows, rotate V0 to set the value of the current data bit; Press 

V0 again, and the arrow in the upper left corner of the data menu will change to a left or 

right arrow. Rotate V0 to select the data bit that needs to be set.   

: Horizontal arrow, rotate V0 to select a number.    

: Vertical arrow, rotate V0 to set the value of the selected number. 

7. Overtime: 

Click on the Overtime menu tab and set the setting value by rotating the multifunctional 

knob V0, with a range of 8ns-10s. Before searching for triggers on the oscilloscope, the 

clock (SCK) signal needs to remain idle for a certain amount of time. When the data 

(SDA) meets the triggering conditions, the oscilloscope will trigger. 

8. Mode: 

Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

9. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 

8.4.14 I2C Trigger                                          

I2C (Inter Integrated Circuit Bus) integrated circuit bus, designed by NXP (formerly 

PHILIPS) company, is mainly used for master-slave communication between master 

controllers and slave devices. It is used in small data volume situations, has short 

transmission distance, and can only have one host at any time. I2C address addressing 

mode is divided into 7-bit addressing mode and 10 bit addressing mode. 

7-bit addressing: In the 7-bit addressing process, the slave address starts transmission 

from the first byte after the start signal. The first 7 bits of this byte are the slave 
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address, and the 8th bit is the read write bit, where 0 represents write and 1 represents 

read. 

10 bit addressing: The 10bit and 7bit addressing of the I2C bus are compatible, 

allowing devices that use both 7bit and 10bit address modes on the same bus. When 

transmitting a 10bit address, the first byte is a special reserved address to indicate that 

the current transmission is a 10bit address. 

 

Figure 8.13 Schematic Diagram of I2C Protocol 

Click on [TRIG MENU] in the button area to open the trigger menu. 

 

1. Type: 

Click on the Type menu label and select "I2C trigger" to set the I2C trigger. 

2. Clock source: 

Click on the SLK menu tab and select CH1-CH2. 

3. Data source: 

Click on the SDA menu tab and select CH1-CH2. 

4. Address: 
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Click on the Address menu tab and set the address by rotating the multifunctional knob 

V0. 

Set the data using V0. When the up and down arrows are displayed in the upper left 

corner of the data menu, rotate the V0 setting value; Press V0 again, and the arrow in 

the upper left corner of the data menu will change to a left or right arrow. Rotate V0 to 

select the desired value.   

: Horizontal arrow, rotate V0 to select a number.    

: Vertical arrow, rotate V0 to set the value of the selected number. 

5. Level: 

Click on the Level menu tab to set the levels of SCL and SDA. 

6. When: 

Click on the When menu tab to select the desired trigger condition. 

⚫ Start Bit: IIC start condition trigger detected. (Triggered when SCL is high and SDA 

data jumps from high level to low level.) 

⚫ Stop Bit: IIC stop condition triggered detected. (Triggered when SCL is high and 

SDA data jumps from low to high.) 

⚫ No Ack: Triggered if SDA data is high during any SCL clock bit. 

⚫ Address: Trigger the search for the set address value and trigger it on the 

read/write bit. The address bit width is "7 bits", so the address range can be from 0 

to 0x7F. 

⚫ Restart: Triggered when a new start condition appears before the stop condition. 

⚫ Address and Data: Trigger to search for the set address and data value on the 

data line (SDA), and trigger on the clock line (SCL) transition edge of the last bit of 

the data. After selecting 'Address and Data' as the triggering condition: 

Click on the Data Index menu tab, set the range from 0 to 3, and you can set four 

data values. 

When clicking on the Data Mask menu tab and setting it to "on", the data in that 

index will be ignored when triggered; Set to 'off', the data on the data line must be 

consistent with the data in the index in order to trigger. 

Click on the Data menu tab and set the data by rotating the multifunctional knob 

V0. 

Set the data using V0. When the arrow in the upper left corner of the data menu 

displays up and down arrows, rotate V0 to set the value of the current data bit; 

Press V0 again, and the arrow in the upper left corner of the data menu will change 

to a left or right arrow. Rotate V0 to select the data bit that needs to be set.   

: Horizontal arrow, rotate V0 to select a number.    

: Vertical arrow, rotate V0 to set the value of the selected number. 

7. Mode: 
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Click on the Mode menu tab and select the trigger mode as automatic or normal. 

⚫ Automatic: When the oscilloscope meets the triggering conditions, it completes 

one triggered acquisition; When the triggering conditions are not met, the 

waveform can be freely collected and run.   

⚫ Normal: When the oscilloscope meets the triggering conditions, it displays the 

input waveform; When the triggering conditions are not met, the original waveform 

is displayed. 

8. Holdoff: 

Click on the Holdoff menu tab and set the Holdoff by rotating the multifunction knob 

V0. Set the waiting time from one trigger to the next on the oscilloscope to ensure 

stable display of complex waveforms. 
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9 Math Operation                         
This series of oscilloscopes supports algebraic and FFT operations between various 

analog channel waveforms. 

You can enter the Math menu through the following methods: 

⚫ Click [Math] in the button area to enter the mathematical operation menu. 

This chapter includes: 

⚫ Arithmetic Operations 

⚫ FFT 
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9.1 Arithmetic Operations                                 

The algebraic operations supported by this series of oscilloscopes include: A+B, A-B, 

A*B, A/B. 

⚫ Addition: Add the signals from source A and source B point by point and display 

the calculation results. 

⚫ Subtraction: Subtract the signals from source A and source B point by point and 

display the calculation results. 

⚫ Multiplication: Multiply the signals of source A and source B point by point and 

display the calculation results. 

⚫ Division: Divide the signals of source A and source B point by point and display the 

calculation results. 

 

1. Operator: 

Click on the Operator menu tab and select algebraic operations such as A+B addition, 

A-B subtraction, A * B multiplication, and A/B division. 

2. Source 1, Source 2: 

After clicking on Source 1 or Source 2, a menu will appear where you can select the 

source as CH1, CH2. Channels in closed state cannot be selected. 

3. Offset: 

Click on the Offset menu tab and set the vertical offset of the calculation result display 

window by rotating the multifunctional knob V0. 
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4. Scale: 

Click on the Scale menu label and set the vertical gear of the calculation result display 

window by rotating the multifunctional knob V0. 

9.2 FFT                                                 

 

1. Operator: 

Click on the Operator menu tab and select FFT operation. 

2. Source: 

Click on the dropdown box of the information Source item to select the information 

source as CH1, CH2. Channels in closed state cannot be selected. 

3. Center: 

Click on the Center menu tab and rotate the multifunction knob V0 to set the center 

frequency. 

4. Span: 

Click on the Span menu tab and rotate the multifunction knob V0 to set the frequency 

span. 

5. Ref Level: 

Click on the Ref Level menu tab and set the vertical offset of the calculation result 

display window by rotating the multifunction knob V0. 
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6. Scale: 

Click on the Scale menu label and set the vertical gear of the calculation result display 

window by rotating the multifunctional knob V0. 

7. Vertical Units: 

Click on the Vertical Units menu tab to select dB or VRms. 

8. Window: 

The use of window functions can effectively reduce spectral leakage effects. This series 

of oscilloscopes provides the following table, showing 6 FFT window functions, each 

with different characteristics and suitable waveforms for measurement. Selection 

should be made based on the measured waveform and its characteristics. Click the 

Window menu to make a selection. 

Table 9.1 Window Function 

Window Function Characteristics 
Waveforms Applicable to the 

Window Function 

Rectangular 

A dedicated window for 

discontinuous waveforms. It is 

basically similar to the situation 

without adding a window. 

Transient and short pulse 

waveforms. 

Hanning 
Better frequency resolution, 

poorer amplitude resolution. 
Period Waveform. 

Hamming 

Slightly better frequency 

resolution than the Hanning 

window. 

Transient and short pulse 

waveforms. 

Blackman-Harris 
The best amplitude resolution, 

the worst frequency resolution. 

Single frequency signal, 

searching for higher 

harmonics. 

Triangle Better frequency resolution. Strong narrowband signal 

Flattop 
Better amplitude resolution, 

poorer frequency resolution. 
Period Waveform. 

9. Show Only: 

Click on the Show-Only menu tab and select whether to display the FFT function 

separately. 

10. AutoScale: 

Click the AutoScale setting button, and the instrument will automatically adjust the 

vertical gear and offset of the calculation result to the optimal value based on the 

current configuration, making it easier for users to observe. 
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10 Measure                               
The voltage time coordinate graph displayed by the oscilloscope can be used to 

measure the displayed waveform. There are various methods for measuring, including 

screen grid scale, cursor, or automatic measurement. 

The menu can be accessed through the following methods: 

⚫ Click on the button area [Measure] to enter the measurement menu. 

This chapter includes: 

⚫ Source 

⚫ Type 

⚫ DVM 

⚫ Statistics 

⚫ Clear All 

⚫ All Measure 

⚫ Settings 

⚫ Gate 

⚫ Quick Measurement after AUTO 
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10.1 Source                                           

Click on the Source source menu tab and select the measured data sources CH1 and 

CH2. Only open data sources can be selected. 

10.2 Type                                             

Click on the Type menu tab and select the measurement item using the multifunction 

knob V0. 

1. PkPk: The voltage value from the highest point to the lowest point of the 

waveform. 

PkPk = Vmax - Vmin 

2. Frequency: defined as the reciprocal of period. 

3. Average: the arithmetic mean value of the whole waveform or gate area. 

4. Vmax: The voltage value from the highest point of the waveform to GND (ground). 

5. Vmin: The voltage value from the lowest point of the waveform to GND (ground). 

6. Period: defined as the time between the middle threshold points of two 

consecutive, like-polarity edges. 

7. Vtop: The voltage value from the flat top of the waveform to GND (ground). 

8. Vmid: The actual voltage value corresponding to the intermediate value of the 

measurement threshold. 

9. Vbase: The voltage value from the flat bottom of the waveform to GND (ground). 

10. Vamp: The voltage value from the top to the bottom of the waveform. 

Amplitude = Vtop - Vbase 

11. RMS: The root mean square value on the entire waveform or gating region. 

12. OverShoot: The ratio of the difference between the maximum value of the rising 

edge and the top value of the waveform to the amplitude 

13. PreShoot: The ratio of the difference between the minimum value of the falling 

edge of the waveform and the bottom value to the amplitude. 

14. PerRms: The root mean square value within a period. 

 

Among them, xi is the measurement result of the i-th point, and n is the number of 

measured points. 

15. PrdAvg: The arithmetic mean of the first cycle of the waveform. 
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Among them, xi is the measurement result of the i-th point, and n is the number of 

points measured.   

16. Rise Time: indicates the time for the signal amplitude to rise from the threshold 

lower limit to the threshold upper limit. 

17. Fall Time: indicates the time for the signal amplitude to rise from the threshold 

upper limit to the threshold lower limit. 

18. +Width: indicates the time between the threshold middle value of a rising edge to 

the threshold middle value of the next falling edge. 

19. -Width: indicates the time between the threshold middle value of a falling edge to 

the threshold middle value of the next rising edge. 

20. +Duty: indicates the ratio of the positive pulse width to the period. 

 

21. -Duty: indicates the ratio of the negative pulse width to the period. 

 

22. FRR: ↑ A ->↑ B, the time difference between the first rising edge of data source 

A and data source B. 

23. FFF: ↓ A ->↓ B, the time difference between the first falling edge of data source 

A and data source B. 

24. FOV: The ratio of the difference between the maximum value of the falling edge 

and the top value of the waveform to the amplitude. 

25. FPRE: The ratio of the difference between the minimum value of the rising edge 

and the bottom value of the waveform to the amplitude. 

26. Bandwidth: The time from the first edge of the data source to the last edge of the 

data source. 

27. FRF: ↑ A ->↓ B, the time difference between the first rising edge of data source 

A and the first falling edge of data source B. 

28. FFR: ↓ A ->↑ B, the time difference between the first falling edge of data source 

A and the first rising falling edge of data source B. 

29. LRR: ↑ A ->↑ B, the time between the first rising edge of data source A and the 

last rising edge of data source B. 

30. LRF: ↑ A ->↓ B, the time between the first rising edge of data source A and the 

last falling edge of data source B. 

31. LFR: ↓ A ->↑ B, the time between the first falling edge of data source A and the 

last rising edge of data source B. 
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32. LFF: ↓ A ->↓ B, the time between the first falling edge of data source A and the 

last falling edge of data source B. 

10.3 DVM                                             

Click on the DVM menu tab to enter the settings menu of the digital voltmeter. 

1. Enable: 

Click on the CH1 Enable or CH2 Enable menu tab and select to turn on or off CH1 

Enable or CH2 Enable. Only open channels can be set. 

2. Type: 

Click on the CH1 Type or CH2 Type menu tab and select the type displayed on the 

digital voltmeter: DC RMS, AC RMS, DC. 

⚫ DC RMS: Display the root mean square value of the collected data. 

⚫ AC RMS: displays the root mean square value of the collected data with the DC 

component removed. 

⚫ DC: Display the DC value of the collected data. 

3. Return: 

Click on the Return menu tab to go back to the previous menu. 

10.4 Statistics                                         

Click on the [Meas] -> Statistics menu tab and select to turn on or off the statistics 

function. Opening the statistics function will display the current value, average value, 

minimum value, maximum value, root mean square error, and count of the opened 

measurement items. 

10.5 Clear  All                                         

Click on [Meas] ->Clear All Menu Tags, and clear all measurement parameter 

statistical functions displayed on the screen. 

10.6 All Measure                                       

Click on the [Meas] -> All Measurement menu tab, and all measurement items will be 

displayed on the screen. 
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Figure 10.1 All Measure 

10.7 Settings                                          

Click on [Meas] -> Settings menu tab to open the settings menu. When selecting 8 

types of delay measurements: FRR, FFF, FRF, FFR, LRR, LRF, LFR, and LFF, the data 

source selected in the measurement menu is set as data source A. In the settings 

menu, the opened channel can be set as data source B for delay measurement. 

10.8 Gate                                             

Click on the [Meas] -> Gate Control Menu tab to open the Gate Control Settings menu. 

Gate control measurement can only be opened when the measurement type is 

enabled. After opening the door control measurement, the measurement result only 

measures the waveform between cursor A and B. 

10.9 Quick Measurement after AUTO                       

After connecting the oscilloscope correctly, input a valid signal, press the [Auto Scale] 

button to automatically set the waveform and open the following function menu: 

⚫ Single cycle: Set the screen to automatically display signals for a single cycle. 

Simultaneously measure the "time parameter" and "voltage parameter" of the 

current data source in a single cycle, and the measurement results are displayed 

at the bottom of the screen. 
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⚫ Multi cycle: Set the screen to automatically display signals for multiple cycles. 

Simultaneously perform multi cycle "time parameter" and "voltage parameter" 

measurements on the current data source, and the measurement results are 

displayed at the bottom of the screen. 

⚫ Automatic range: Select the scale automatically set by the system: "Horizontal 

vertical gear", "Horizontal gear", or "Vertical gear". 

⚫ Data source: Set the channels to be automatically set: "Display only", "All". Display 

only: After the system performs automatic settings, only the waveform of the 

opened channel with signal input is displayed; All: After the system performs 

automatic settings, the waveforms of all channels with signal inputs are displayed. 
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11 Cursor Measurement                                 
The cursor can be used to measure the X-axis value (such as time) and Y-axis value 

(such as voltage) of the selected waveform. Before using the cursor for measurement, 

we need a stable waveform display. 

⚫ X cursor 

The X cursor is a vertical dashed line used for horizontal adjustment, which can be 

used to measure time (s) and frequency (Hz). 

⚫ Y cursor 

The Y cursor is a horizontal dashed line used for vertical adjustment, which can be 

used to measure amplitude (consistent with the source channel amplitude unit). 

Click the [Cursor] button in the key area to enter the cursor settings menu. The 

selected modes are: none, manual, and tracking. When selecting manual cursor or 

tracking cursor, a window for cursor measurement will appear on the screen, displaying 

the measurement results. 

⚫ Manual Mode 

⚫ Track Mode 
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11.1 Manual Mode                                           

In manual cursor mode, the value of the specified signal source waveform at the current 

cursor can be measured by manually adjusting the cursor. If the settings of parameters 

such as cursor type and measurement source are different, the results obtained by 

using the cursor will also be different. 

Click the [Cursors] in the button area to enter the cursor setting menu. The cursor 

defaults to off mode. 

Click on the Mode menu tab and select the cursor mode as manual. In the window 

where the measurement results are displayed, the window can be moved. By changing 

the cursor position, the measurement results also change in real-time. 

 

AX: The X value at cursor A. 

BX: The X value at cursor B. 

BX-AX: Horizontal spacing between cursors A and B. 

|1/dX |: The reciprocal of the horizontal spacing between cursors A and B. 

AY: The Y value at cursor A. 

BY: The Y value at cursor B. 

BY-AY: The vertical spacing between cursors A and B. 

1. Source: 

Click on the Source menu tab, and the optional source channels are CH1, CH2, 

MATH.Only the currently open channels are selectable. 

2. AX: 

Click on the AX menu label to select the horizontal position of cursor A. After selection, 

rotate the knob V0 to adjust the cursor position. 

3. BX: 

Click on the BX menu label to select the horizontal position of cursor B. After selection, 

rotate the knob V0 to adjust the cursor position. 

4. AXBX: 

Click on the AXBX menu tab to select both the horizontal positions of cursor A and 
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cursor B. After selection, rotate knob V0 to simultaneously adjust the positions of cursor 

A and cursor B. The horizontal spacing between cursor A and cursor B remains 

unchanged. 

5. AY: 

Click on the AY menu label to select the vertical position of cursor A. After selection, 

rotate the knob V0 to adjust the cursor position. 

6. BY: 

Click on the BY menu label to select the vertical position of cursor B. After selection, 

rotate the knob V0 to adjust the cursor position. 

7. AYBY: 

Click on the AYBY menu label to select both the vertical positions of cursor A and 

cursor B. After selection, rotate knob V0 to simultaneously adjust the positions of cursor 

A and cursor B. The vertical spacing between cursor A and cursor B remains 

unchanged. 

8. Test example: 

 

Figure 11.1 Manual Cursor Measurement Example 

11.2 Track Mode                                             

In tracking cursor mode, two cursors (cursor A and cursor B) can be adjusted to 

measure the X and Y values of two different sources, respectively. When moving the 

cursor horizontally/vertically, the marker will automatically position on the waveform. 
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When expanding or compressing the waveform horizontally/vertically, the marker will 

track the point marked during the last adjustment of the cursor. 

Click the [Cursors] button in the button area to enter the cursor setting menu. The 

cursor defaults to off mode. 

Click on the Mode menu tab and select the cursor mode as tracking. In the window 

where the measurement results are displayed, the window can be moved. By changing 

the cursor position, the measurement results also change in real-time. 

 

AX: The X value at cursor A. 

BX: The X value at cursor B. 

BX-AX: Horizontal spacing between cursors A and B. 

|1/dX |: The reciprocal of the horizontal spacing between cursors A and B. 

AY: The Y value at cursor A. 

BY: The Y value at cursor B. 

BY-AY: The vertical spacing between cursors A and B. 

1. Source: 

Click on the Source menu label, and the available information sources include 

CH1~CH2 and Math. 

2. AX: 

Click on the AX menu label to select the horizontal position of cursor A. After selection, 

rotate the knob V0 to adjust the cursor position. 

3. BX: 

Click on the BX menu label to select the horizontal position of cursor B. After selection, 

rotate the knob V0 to adjust the cursor position. 

4. AXBX: 

Click on the AXBX menu tab to select both the horizontal positions of cursor A and 

cursor B. After selection, rotate knob V0 to simultaneously adjust the positions of cursor 

A and cursor B. The horizontal spacing between cursor A and cursor B remains 

unchanged. 

5. Measurement example: 
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Figure 11.2 Track Measurement (before Horizontal Expansion) 

 

Figure 11.3 Track Measurement (after Horizontal Expansion) 
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12 Display                                 
In the display settings menu, users can set the waveform display type, afterglow time, 

waveform brightness, grid type and brightness displayed on the screen, etc. 

Click on the button area [Display] to enter the display settings menu. 

 

This chapter includes: 

⚫ Type 

⚫ Intensity 

⚫ Gird 

⚫ To Set the Gird Brightness 

⚫ To Set the Screen Brightness 

⚫ Persist 
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12.1 Type                                            

Click on the Type menu tab to select between Vector and Point. Choose whether to 

display waveforms as vectors or dots. Vector settings will fill the gaps between adjacent 

sampling points in the display; The point setting only displays sampling points. 

Vector type sampling points are displayed by connecting lines between them. This 

mode provides the most realistic waveform in most cases, making it easy to view the 

steep edges of waveforms (such as square waves). 

12.2 Intensity                                          

Click the Intensity menu button and set the brightness value through the 

multifunctional knob V0, with a range of 0% to 100%. 

12.3 Grid                                              

Click on the Grid menu tab to select the types of screen grids: Dot, Line, and Close. 

⚫ Dot: Set the background grid line as a point. 

⚫ Line: Set the background grid to solid lines. 

⚫ Close: Close the background grid. 

12.4 To Set the Grid Brightness                         

Click on the Gridicule menu tab and set the grid brightness value directly through the 

multi-functional knob V0 or the numeric keypad, with a range of 0%~100%. 

12.5 To Set the Screen Brightness                      

Click on the Brightness menu button, and set the brightness value directly through the 

multi-functional knob V0 or the numeric keypad, with a range of 0%~100%. 

12.6 Persist                                           

In the display menu, click on the afterglow menu tab and select the afterglow time (off, 

infinite, 1s, 5s, 10s, 30s). 

⚫ Minimum value: The waveform that changes at a high refresh rate can be 

observed.    
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⚫ Specific value: Can observe burrs with slow changes or low probability of 

occurrence. The afterglow time can be set to 1 s, 5 s, 10 s, and 30 s. 

⚫ Infinite: When the oscilloscope displays a newly acquired waveform, it will not clear 

the previously acquired waveform. The collected waveforms will be displayed in 

colors with lower brightness, while newly collected waveforms will be displayed in 

normal brightness and color. Using infinite afterglow to measure noise and jitter, 

capturing occasional events. 
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13 System Utility Function Setting         
Click on [Utility] in the button area. Enter system configuration. 

Users can set system related functional parameters or interfaces. 

This chapter includes: 

⚫ Language 

⚫ Sound 

⚫ Update 

⚫ Pass/Fail 

⚫ System Info 

⚫ Calibrate 

⚫ FrontPanel Selftest 

⚫ Legal Information 
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13.1 Language                                           

Click on the [Utility] -> Language menu tab to switch between 14 languages, including 

Chinese or English. 

13.2 Sound                                            

Click on the [Utility] -> Sound menu tab, and the sound can be turned off or on. 

13.3 Update                                            

Click on [Utility] -> Upgrade menu tab. 

This series of oscilloscopes can experiment with upgrading firmware for USB storage 

devices, and the entire process takes approximately 5 minutes.   

Follow these steps to upgrade the firmware: 

⚫ Insert the USB storage device with the upgrade package into the USB HOST 

interface on the front panel of the oscilloscope.    

⚫ Press the [Utility] button to enter the auxiliary menu.    

⚫ Press the Upgrade -> Upgrade Firmware software button.   

⚫ Rotate V0 to select the upgrade file and press V0 to confirm. Then press the Start 

Upgrade soft key to upgrade the firmware.   

⚫ After the upgrade is completed, the oscilloscope will restart and the firmware 

version will also be updated. The oscilloscope should self calibrate after 

upgrading. 

13.4 Pass/Fail                                            

Testing functions can better monitor changes in signals. You can enter the testing menu 

through the following methods: 

⚫ In [Utility] -> Pass/Fail, enter the Pass/Fail function menu. 
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13.4.1 To Enable or Disable the Pass/Fail Test Function           

Click on the Pass/Fail menu tab to enter the Pass Test Settings menu. 

Click on the Enable menu tab to select whether to enable or disable the pass testing 

function. The icon illuminates to enable the pass test function. 

13.4.2 To Select the Source                                      

Click on the Source Selection menu tab in the Test menu to select channels CH1 to 

CH2. 

13.4.3 Regular                                             

Click on the Regular menu tab in the pass test menu to create pass/fail rules. 

1. Vertical 

Click on Regular -> Vertical, use the V0 knob to set the vertical tolerance range: 

0.020div -4.00div. 

2. Level 

Click on Regular -> Horizontal, use the V0 knob to set the horizontal tolerance range: 

0.025div-8.00div. 

3. Create 
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Click on Regular -> Create, and create a rule template based on the vertical and 

horizontal settings. 

4. Save 

Click on Regular -> Save, and select the storage location for the rules. 

4.1 Save Directory 

Click on Regular -> Save -> Save To, select the location to save, and 

internal flash memory should be stored in 1-10 locations. 

4.2 Save 

Click on Regular -> Save -> Save to save the rule settings. 

4.3 Transfer out 

Click on Regular -> Save -> Recall to retrieve the waveform rule settings. 

13.4.4 Message                                            

Click on Pass/Fail -> Message, select to turn on or off the display information for the 

number of failed attempts. 

13.4.5 Mode                                                  

Click on Pass/Fail -> Mode, select Pass, Fail, Pass Ring, Fail Ring. 

⚫ Pass: Output a negative pulse train during testing. 

⚫ Fail: Negative pulse train output during failed test. 

⚫ Pass Ring: When passing the test, output a negative pulse train accompanied by 

ringing. 

⚫ Fail Ring: During the failed test, a negative pulse train is output, accompanied by a 

ringing sound. 

13.4.6 Run                                                 

Click on Pass/Fail -> Run, run pass/fail test. 

13.4.7 Stop                                                

Click on Pass/Fail -> Stop to stop the pass/fail test. 

13.4.8 Out Stop                                            

Click on Pass/Fail -> Out Stop, select on or off, enter STOP state when there is output 

or continue running when there is output. 
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13.5 System Info                                       

Click on [UTILITY] -> System Info to display the software version, hardware version, 

serial number, and other information of the oscilloscope. 

13.6 Calibrate                                         

Click on [UTILITY] -> Calibrate, press this soft key, and a self calibration dialog box will 

pop up. Follow the prompts to self calibrate or cancel. 

The self calibration program can optimize the oscilloscope signal path with maximum 

measurement accuracy. You can run this program at any time, but it should be run if the 

ambient temperature changes by more than 5 ℃ or more. To calibrate more accurately, 

please turn on the oscilloscope power, preheat for 20 minutes, and then perform self 

calibration. Follow the on-screen prompts to operate.   

To compensate for the signal path, disconnect any probes or cables connected to the 

front panel input connector, press the [Utility] button, select the "Self Calibration" 

option, and follow the instructions on the display screen. 

13.7 FrontPanel Selftest                                

Click on [Utility] -> FrontPanel Selftest to test the functionality of all buttons, knobs, 

and LED lights on the front panel. 

13.8 Legal Information                                 

Click on [Utility] -> Legal Information to display the source code license. 



Decode 

  EN 

DSO2D20 User manual                                              Copyright © Qingdao Hantek Electronic Co., LTD 

98 

14 Decode                               
Protocol decoding is the foundation of protocol analysis. Only correctly decoded 

protocol analysis can be accepted, and only correct decoding can provide more error 

information. This oscilloscope provides commonly used protocol decoding, including 

UART, I2C, SPI, LIN, and CAN. You can enter the decoding menu through the following 

methods: 

Click on the button area [Decode] to enter the decoding settings menu. 

This chapter includes: 

⚫ UART Decode 

⚫ LIN Decode 

⚫ CAN Decode 

⚫ SPI Decode 

⚫ IIC Decode 
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14.1 UART Decode                                     

The UART serial bus consists of a transmit data line (TX) and a receive data line (RX). 

 

Figure 14.1 Schematic Diagram of UART Serial Bus 

The industry standard for RS232 uses "negative logic", which means that high levels 

represent logic "0" and low levels represent logic "1". 

 

Figure 14.2 Schematic Diagram of Negative Logic 

The baud rate is used in RS232 to represent the transmission rate of data (i.e. bits per 

second). RS232 requires setting the start bit, data bit, check bit (optional), and stop bit 

for each frame of data. 

 

⚫ Start Bit: indicates when the data starts to be output. 

⚫ Data Bit: represents the actual number of data bits contained in each frame of 

data. 

⚫ Check Bit: used to verify the correctness of data transmission. 

⚫ Stop Bit: indicates when the data stops outputting. 

Click [Decode] in the button area to enter the decoding function menu. 
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1. Bus Type: 

Click on the Type menu tab and select UART from the pop-up menu to configure UART 

decoding. 

2. Source: 

Click on the Source menu tab and select CH1, CH2. 

3. Idle Level: 

Click on the Idle Level menu tab and set the idle level to low or high. 

4. Label Position: 

Click on the Label Position menu label and set the position using the V0 knob. 

5. Baud Rate: 

Click on the Baud Rate menu tab and select baud rate from the pop-up menu. 

Select Custom, you can set the Baud User through the V0 knob in the Custom menu 

tab. 

6. Parity: 

Click on the Parity menu tab, and the available check methods are: no check, odd 

check, and even check. 

⚫ None: There is no checksum during transmission. 

⚫ Odd: The total number of "1" in the data bit and check bit is odd. For example, if 

0x55 (01010101) is sent, the verification position needs to be filled with 1. 

⚫ Even: The total number of "1" in the data bits and check bits is even. For example, 

if 0x55 (01010101) is sent, it is necessary to fill in 0 in the verification position. 
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7. Data Bits: 

Click on the Data Bits menu tab, and the available data bits are: 5 bits, 6 bits, 7 bits, 

and 8 bits. 

8. Disp: 

Click on the Disp menu tab and select synchronous decoding or protocol monitoring. 

14.2 LIN Decode                                       

The oscilloscope samples the LIN signal and determines whether each data point is a 

logic "1" or a logic "0" based on the set threshold level. LIN decoding requires 

specifying the LIN signal protocol version. 

Click [Decode] in the button area to enter the decoding function menu. 

 

1. Bus Type: 

Click on the Type menu tab and select LIN from the pop-up menu to configure LIN 

decoding. 

2. Source: 

Click on the Source menu tab and select CH1, CH2. 

3. Label Position: 

Click on the Label Position menu label and set the position using the V0 knob. 

4. Baud Rate: 
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Click on the Baud Rate menu tab and select baud rate from the pop-up menu. 

Select Custom, you can set the Baud User through the V0 knob in the Custom menu 

tab. 

5. Idle Level: 

Click on the Idle Level menu tab and set the idle level to low or high. 

6. Disp: 

Click on the Disp menu tab and select synchronous decoding or protocol monitoring. 

14.3 CAN Decode                                       

The oscilloscope samples CAN or CAN-FD signals at the designated sampling position, 

and will also determine whether each data point is a logic "1" or a logic "0" based on the 

set threshold level. CAN decoding requires specifying the CAN or CAN-FD signal type 

and sampling location. 

Click [Decode] in the button area to enter the decoding function menu. 

 

1. Bus Type: 

Click on the Type menu label and select CAN from the pop-up menu to configure CAN 

decoding. 

2. Source: 

Click on the Source menu tab and select CH1, CH2. 

3. Label Position: 

Click on the Label Position menu label and set the position using the V0 knob. 
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4. Baud Rate: 

Click on the Baud Rate menu tab and select baud rate from the pop-up menu. 

Select Custom, you can set the Baud User through the V0 knob in the Custom menu 

tab. 

5. Idle Level: 

Click on the Idle Level menu tab and set the idle level to low or high. 

6. Disp: 

Click on the Disp menu tab and select synchronous decoding or protocol monitoring. 

14.4 SPI Decode                                         

SPI bus communication is based on master-slave configuration and generally consists 

of clock lines (CLK) and data lines (SDA). The data lines include MISO (master input 

slave output) and MOSI (master output slave input). The oscilloscope samples channel 

data on the rising or falling edge of the clock signal (if it is an analog channel, it will also 

determine whether each data point is a logical "1" or a logical "0" based on the set 

threshold level). 

 

Figure 14.3 SPI Bus Schematic 

Click [Decode] in the button area to enter the decoding function menu. 
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1. Bus Type: 

Click on the Bus Type menu tab and select SPI from the pop-up menu to configure SPI 

decoding. 

2. Source: 

Click on the SCK or MOSI/MISO menu tab and select CH1, CH2. 

3. Slope: 

Click on the Slope menu tab and select whether the slope is rising or falling. 

4. Label Position: 

Click on the Label Position menu label and set the position using the V0 knob. 

5. Data Width: 

Click on the Data Width menu tab and select bit widths of 4, 8, 16, 24, and 32. 

6. Overtime: 

Click on the Overtime menu tab and set the timeout time using the V0 knob. 

7. Disp: 

Click on the Disp menu tab and select synchronous decoding or protocol monitoring. 

14.5 IIC Decode                                          

The I2C serial bus consists of a clock line (SCL) and a data line (SDA). 
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Figure 14.4 Schematic diagram of I2C serial bus 

⚫ SCL: Sampling SDA on the rising or falling edge of the clock. 

⚫ SDA: Represents a data channel. 

Click [Decode] in the button area to enter the decoding function menu. 

 

1. Bus Type: 

Click on the Type menu tab and select I2C from the pop-up menu to configure I2C 

decoding. 

2. Source: 

Click on the SCL or SDA menu tab and select CH1 or CH2. 

3. Label Position: 

Click on the Label Position menu label and set the position using the V0 knob. 

4. Disp: 

Click on the Disp menu tab and select synchronous decoding or protocol monitoring. 
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15 Store and Load                         
Users can save the current oscilloscope settings, waveforms, screen images, and 

parameters in various formats to internal memory 

Or an external USB storage device (such as a USB flash drive), and can reload saved 

settings or waveforms when needed. 

In addition, users can perform replication on specified types of files in internal storage 

or external USB drives through the disk management menu 

Operations such as creating, deleting, and renaming. 

This chapter includes: 

⚫ Internal SAVE and RECALL 

⚫ External SAVE and RECALL 

⚫ File Managerment 
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15.1 Internal SAVE and RECALL                                        

Click the [SAVE/RECALL] button in the button area to open the save/recall menu. 

15.1.1 Internal SAVE                                       

1. Save settings: 

Click on the Type menu tab, select SetUp, and save the settings. 

⚫ Save Directory: Click on the Save To menu tab, select Internal, and save the 

current settings of the oscilloscope to the internal memory. 

⚫ Location: Click on the SetUp menu label, rotate V0 to select the save location. The 

internal flash memory can store up to 9 files, No.1～No.9. 

⚫ Save: Click on the Save menu tab to save the current settings of the oscilloscope 

to the specified location. After a few seconds, a prompt message saying 'Save 

Successfully' will pop up. 

2. Save waveform: 

Click on the Type menu tab, select the waveform, and save the waveform. 

⚫ Save Directory: Click on the Save To menu tab, select Internal, and save the 

current waveform of the oscilloscope to the internal memory. 

⚫ Location: Click on the SetUp menu label, rotate V0 to select save waveform. The 

internal flash memory can store up to 9 files, No.1～No.9. 

⚫ Save: Click on the Save menu tab to save the current waveform of the 

oscilloscope to the specified location. After a few seconds, a prompt message 

saying 'Save Successfully' will pop up. 

3. Save reference: 

Click on the Type menu tab, select Reference, and save the reference. 

⚫ Data Source: Click on the Source menu tab and select CH1, CH2, Math. 

⚫ Save Directory: Click on the Save To menu tab, select Internal, and save the 

current reference waveform of the oscilloscope to the internal memory. 

⚫ Location: Click on the SetUp menu label, rotate V0 to select save reference 

waveform. The internal flash memory can store up to 9 files, No.1～No.9. 

⚫ Save: Click on the Save menu tab to save the current reference waveform of the 

oscilloscope to the specified location. After a few seconds, a prompt message 

saying 'Save Successfully' will pop up. 
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15.1.2 Internal RECALL                                    

1. Recall SetUp: 

Click on the Type menu tab, select SetUp, and save the settings. 

⚫ Recall From: Click on the Recall From menu tab, select Internal, and transfer the 

saved file to the oscilloscope. 

⚫ Location: Click on the SetUp menu tab, rotate V0 to select the previously saved 

location, and bring up the settings. 

⚫ Recall: Click on the Recall menu tab to transfer out the settings. After completion, 

a prompt message "Recall Successfully" will pop up. 

2. Recall Waveform: 

Click on the Type menu tab, select the waveform, and save the waveform. 

⚫ Recall From: Click on the Recall From menu tab, select Internal, and transfer the 

saved file to the oscilloscope. 

⚫ Location: Click on the SetUp menu label, rotate V0 to select the previously saved 

location, and bring up the waveform. 

⚫ Recall: Click on the Recall menu tab to transfer out the waveform. After 

completion, a prompt message "Recall Successfully" will pop up. 

3. Recall Reference: 

Click on the Type menu tab, select Reference, and save the reference. 

⚫ Channel: Click on the Channel menu tab and select RefA or RefB. 

⚫ Recall From: Click on the Recall From menu tab, select Internal, and transfer the 

saved file to the oscilloscope. 

⚫ Location: Click on the SetUp menu label, rotate V0 to select the previously saved 

location, and bring up the reference waveform. 

⚫ Recall: Click on the Recall menu tab to bring up the reference waveform. After 

completion, a prompt message "Recall Successfully" will pop up. 

15.2 External SAVE and RECALL                       

15.2.1 External SAVE                                       

1. Save SetUp: 

Click on the Type menu tab, select SetUp, and save the settings. 

⚫ Save Directory: Click on the Save To menu tab, select External, and save the 

current settings of the oscilloscope to a USB storage device. 

⚫ Save: Click on the Save menu tab to save the current settings of the oscilloscope 

to a USB storage device. After a few seconds, a prompt message saying 'Save 
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Successfully' will pop up. 

2. Save waveform: 

Click on the Type menu tab, select the waveform, and save the waveform. 

⚫ Save Directory: Click on the Save To menu tab, select External, and save the 

current waveform of the oscilloscope to a USB storage device. 

⚫ Save: Click on the Save menu tab to save the current waveform of the 

oscilloscope to a USB storage device. After a few seconds, a prompt message 

saying 'Save Successfully' will pop up. 

3. Save reference: 

Click on the Type menu tab, select Reference, and save the reference. 

⚫ Source: Click on the Source menu tab and select CH1, CH2, Mathematics. 

⚫ Save Catalog: Click on the Save To menu tab, select External, and save the 

current reference waveform of the oscilloscope to a USB storage device. 

⚫ Save: Click on the Save menu tab to save the current reference waveform of the 

oscilloscope to a USB storage device. After a few seconds, a prompt message 

saying 'Save Successfully' will pop up. 

4. Save CSV: 

Click on the Type menu tab, select CSV, and save CSV. 

⚫ Save: Click on the Save menu tab to save the current CSV of the oscilloscope to a 

USB storage device. After a few seconds, a prompt message saying 'Save 

sSuccessfully' will pop up. 

5. Save image: 

Click on the Type menu tab, select the image, and save the image. 

⚫ Picture Invert: Click on the Picture Invert menu tab and select whether to turn on 

or off the image reverse when saving the image. 

⚫ Save: Click on the Save menu tab to save the current image of the oscilloscope to 

a USB storage device. After a few seconds, a prompt message saying 'Save 

Successfully' will pop up. 

Press the shortcut key [SAVE TO USB] on the front panel to automatically take a 

screenshot and save the image to an external storage device. 

15.2.2 External RECALL                                 

1. Recall SetUp: 

Click on the Type menu tab, select SetUp, and save the settings. 

⚫ Recall From: Click on the Recall From menu tab, select External, and transfer the 

saved file to the oscilloscope. 

⚫ Recall: Click on the Recall menu tab to access the settings. After completion, a 
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prompt message saying "Recall Successful" will pop up. 

2. Recall waveform: 

Click on the Type menu tab, select the waveform, and save the waveform. 

⚫ Recall From: Click on the Recall From menu tab, select External, and transfer the 

saved file to the oscilloscope. 

⚫ Recall: Click on the Recall menu tab to transfer out the waveform. After 

completion, a prompt message of "Recall Successful" will pop up. 

3. Recall reference: 

Click on the Type menu tab, select Reference, and save the reference. 

⚫ Channel: Click on the channel menu tab and select RefA or RefB. 

⚫ Recall From: Click on the Recall From menu tab, select External, and transfer the 

saved file to the oscilloscope. 

⚫ Recall: Click on the Recall menu tab to retrieve the reference waveform. After 

completion, a prompt message will pop up saying "Recall Successful". 

15.3 File Management                                  

15.3.1 New File                                            

This operation is only valid when stored externally. This oscilloscope supports English 

input method. The file or folder name can consist of letters, numbers, and underscores. 

Below, we will introduce the method of creating files or folders through examples.   

Create a file named 'DSOXXXX01'.   

1. After correctly inserting the USB flash drive into the oscilloscope, press the Save 

soft key under the [SAVE/RECALL] menu to enter the USB storage interface.   

2. Press the Type soft key and rotate V0 to select a type.   

3. Use the Save To soft key and select 'External'. Press the Save soft key to enter 

the file management interface.   

4. Press the New soft key to open the New Folder interface as shown below. Divided 

into two areas: name input area and keyboard area. Default switch to "keyboard 

area".   

5. Rotate the multifunctional knob V0 to select "Aa" and press V0 to confirm in order 

to switch the current lowercase English letter to uppercase. Rotate V0 again and 

select "DSOXXXX01" in sequence, then press V0 to confirm.   

6. To delete a name from the current name input area, press the Switch Focus To 

soft key and select 'Name' to switch to the name input area. You can continuously 

press the Delete soft key to delete the characters to the left of the cursor one by 

one. Rotate V0 to move the cursor position.   

7. After completing the input, press the Save soft key, and the oscilloscope will create 

a specified type of file with the file name in the current path. 
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15.3.2 Delete File                                          

This operation is only valid for external storage (USB storage).   

1. After correctly inserting the USB flash drive into the oscilloscope, press the save 

soft key under the [SAVE/RECALL] menu to enter the USB storage interface.   

2. Press the Type soft key and rotate V0 to select a type.   

3. Use the Save To soft key and select 'External'. Press the Save soft key to enter 

the file management interface.   

4. Use the multifunctional knob V0 to select the file or folder that needs to be 

deleted, and press the Delete soft key. 

15.3.3 Rename File                                      

This operation is only valid for external storage (USB storage).   

1. After correctly inserting the USB flash drive into the oscilloscope, press the save 

soft key under the [SAVE/RECALL] menu to enter the USB storage interface.   

2. Press the Type soft key and rotate V0 to select a type.   

3. Use the Save To soft key and select 'External'. Press the Save software to enter 

the file management interface.   

4. Use the multifunctional knob V0 to select the file or folder that needs to be 

renamed, and press the Rename soft key to open the rename interface. For 

specific operation methods, please refer to the instructions in "New File". 
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16 Quik key                              
Automatic setting: Automatically set the oscilloscope controls to generate useful 

displays of input signals. Please refer to the table below for details. 

Click the [Auto Scale] button to automatically set the oscilloscope. 

Default Settings: Automatically call up the default settings. 

Click the [Default Setup] button, and the machine will enter the default setting 

operation. 

This chapter includes: 

⚫ Auto Scale 

⚫ Default Setup 
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16.1 Auto Scale                                          

Automatic setting is one of the advantages of digital oscilloscopes. When you click on 

automatic settings, the oscilloscope will recognize the waveform type and adjust the 

control method to accurately display the waveform of the input signal. 

Table 16.1 Auto Scale 

Parameter Settings 

Acquire Normal 

Cursor Close 

Timebase Mode YT 

Display Vector 

Horizontal Adjusted 

SEC/DIV Adjusted 

Holdoff 20ns 

Trigger Level 50% 

Trigger Mode Auto 

Trigger Source Adjusted 

Trigger Slope Adjusted 

Trigger Type Edge 

Sync Adjusted 

Standard Adjusted 

Bandwidth Close 

Coupling DC 

VOLTS/DIV Adjusted 
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16.2 Default Setup                                        

Press the [Default Setup] button, and the oscilloscope will display waveforms for four 

channels. The following table provides settings for changing options, buttons, and 

controls under default settings. 

Table 16.2 Default Setup  

Horizontal 

Horizontal Time  

Base 
200us 

Horizontal Position 0s 

Delayed Sweep Off 

Timebase Mode YT 

Fine Off 

Horizontal Expansion Center 

Vertical 

Vertical Scale 1V 

Vertical Offset CH1: 2V, CH2: -2V 

CH1/CH2 CH1-CH2 On 

Channel Coupling DC 

BW Limit Off 

Attenuation 1X 

Input Impedance 1MΩ 

Invert Off 

Channel Unit V 

Fine Off 

Ch-Ch Skew 0s 

Offset Cal 0V 

Acquire 

Acquisition Mode Normal 

Memory Depth 4K 

Trigger 
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Trigger Type Edge Trigger 

Source Selection CH1 

Edge Type Rising 

Trigger Holdoff 1us 

Display 

Display Type Vector 

Persistence Time Off 

Intensity 100% 

Grid Line 

Gird Brightness 60% 

Brightness 80% 

AWG 

AWG Off 

Wave Sine 

Frequency 1KHz 

Amplitude 1.5V 

Offset 0V 

Start Phase 0° 

Setting Type Off 

Impedance HighZ 

Cursor 

Mode Off 

Math 

Operator A+B 

Operation Off 
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17 Arbitrary Waveform Generator        
This series of oscilloscopes has a built-in function arbitrary waveform generator, which 

combines the oscilloscope and signal generator to make it more convenient for users to 

use. This chapter introduces the functions of the built-in signal generator in the 

oscilloscope. 

This chapter includes: 

⚫ Output Waveform type 

⚫ Modulation 

⚫ Burst 
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17.1 Output waveform type                           

Click on [WAVE GEN] in the button area to enter the signal generator settings interface 

and select the output of the basic wave. 

1. Waveform: 

Click on the Wave menu tab and select Sine wave, Square wave, Ramp wave, Exp 

wave, Noise, DC, and Arb1-Arb4 from the pop-up menu. 

⚫ Frequency: 

Click on the Frequency menu tab to set the frequency value by rotating knob V0. 

DC and noise: no frequency parameters. 

⚫ Amplitude: 

Click on the Amplitude menu tab to set the amplitude value by rotating knob V0. 

⚫ Offset: 

Click on the Offset menu tab to set the offset value by rotating knob V0. 

⚫ Symmetry/duty cycle: 

Click on the Symmetry/Duty menu tab. When the waveform is a square wave, set 

the waveform duty cycle; When the waveform is a triangular wave, set the 

waveform to symmetry. 

⚫ Impedance: 

Click on the Impedance menu tab to select the output impedance of the signal 

generator as high impedance or 50 Ω. 

17.2 Modulation                                            

The signal generator of this series of oscilloscopes has two modulation methods: 

amplitude modulation and frequency modulation. The modulated waveform consists of 

a carrier wave and a modulated wave. The carrier signal is a waveform signal output by 

a signal generator, and the modulation signal can be selected from the built-in sine 

wave, square wave, or triangular wave of the signal generator. 

Click on the button area [WAVE GEN] to enter the modulation settings menu. 

Click on the Type menu tab to select amplitude modulation (AM), frequency modulation 

(FM), or phase modulation (PM). 

1. Amplitude Modulation (AM): 

Amplitude Modulation (AM) refers to the variation of the amplitude of the carrier wave 

with the modulation wave. 
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Figure 17.1 AM 

⚫ Modulation waveform: 

Click on the Wave menu tab to select waveforms including sine wave, square 

wave, and triangular wave. 

⚫ Modulation frequency: 

Click on the Mod Freq menu tab to set the frequency value by rotating knob V0. 

⚫ Modulation depth: 

Click on the Depth menu tab to set the modulation depth from 0-120 by rotating 

knob V0. 

2. Frequency modulation (FM): 

Frequency Modulation (FM) refers to the variation of the carrier frequency with the 

modulation wave. 
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Figure 17.2 FM 

⚫ Modulation waveform: 

Click on the Wave menu tab to select from sine wave, square wave, and triangular 

wave waveforms. 

⚫ Modulation frequency: 

Click on the Mod Freq menu tab to set the frequency value by rotating knob V0. 

⚫ Deviation: 

Click on the Deviation menu tab to set the offset value by rotating knob V0. 

17.3 Burst                                                

The signal generator of this series of oscilloscopes supports outputting burst waveforms 

with a specified number of cycles. This series of oscilloscopes supports internal or 

manual control of burst waveform output; Supports two burst types: N-loop and infinite. 

The burst setting menu can be accessed through the following methods: 

Click on the button area [Burst] to enter the burst setting menu. 

1. Type of burst: 

Click on the Type menu tab to choose between multiple cycles or infinite. 

⚫ N cycle: When receiving a trigger signal, output a burst waveform with a specific 

number of cycles. 

⚫ Infinite: It is equivalent to setting the number of waveform cycles to infinity, and 

outputting a continuous waveform when receiving a trigger signal. 

2. Counting: 

Click on the count menu tab to set the number of cycles by rotating knob V0. Only 
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when multiple cycles are selected for the burst type, can the number of cycles be set. 

3. Trigger: 

Click on the Trigger menu tab, and press the trigger button to output a pulse train with 

a specified number of cycles. 

 



  Remote Control 

EN 

 

Copyright © Qingdao Hantek Electronic Co., LTD                                               DSO2D20 User manual                                                              

121 

18 Remote Control                         

The oscilloscope can be remotely controlled in the following three methods: 

1. User-defined programming: 

Users can program and control the oscilloscope through the standard SCPI (Standard 

Commands for Programmable Instruments) command. For detailed instructions on 

commands and programming, please refer to the DSO2D20 Programming Manual. 

2. Using IO software: 

Users can use IO software to send commands for remote control of the oscilloscope. It 

is recommended to use the PC software IO provided by Keysight. You can log in to the 

Keysight official website (www.keysight.com) to download the software. 

Operating steps: 

⚫ Establish communication between the oscilloscope and the computer. 

⚫ Run IO and search for oscilloscope resources. 

⚫ Open the remote command control panel and send commands. 

This oscilloscope can communicate with a PC through the following interfaces: 

⚫ Controlled through USB 

This chapter will provide a detailed introduction to how to use the IO software provided 

by Keysight to remotely control the oscilloscope through various interfaces. 

Note: 

Before connecting the communication cable, please turn off the instrument to 

avoid damaging its communication interface. 

18.1 Remote Control via USB                             

1. Connect the device 

Connect the oscilloscope (USB VIEW interface) to the PC (USB HOST interface) using 

a USB data cable. 

2. Install USB driver 

After the oscilloscope is correctly connected to the PC for the first time and turned on, 

the PC will automatically install the driver, as shown in the Device Manager: 

file:///F:/机器型号/2、2G4CH/2G4通道说明书/1/3/www.keysight.com
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3. Search for device resources 

Open IO and the software will automatically search for resources currently connected to 

the PC through a USB interface. You can also click Rescan to search. 

4. View Device Resources 

The searched resources will appear in the USB (USB0) directory, displaying the 

machine model, serial number, version information, and USB interface information. 

5. Control the instrument remotely 

Click on Interactive IO in the IO interface to open the remote command control panel, 

where you can send commands and read data. 
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19 Troubleshooting                        
The following is a list of possible faults and troubleshooting methods that may occur 

during the use of an oscilloscope. When you encounter these faults, please follow the 

corresponding steps to handle them. If you cannot handle them, please contact Hantek 

and provide the equipment information of your machine. 

19.1 After pressing the power switch, the oscilloscope 

did not turn on                

1. Check if the power cord on the side of the oscilloscope is connected properly. 

2. Check if the power switch is pressed. 

3. After completing the above checks, restart the instrument. 

4. If the oscilloscope still cannot be turned on normally, please contact your local 

dealer or directly contact the Hantai technical support department. 

19.2 Serious distortion of input signal                  

1. Check if the oscilloscope probe is properly connected to the BNC channel. 

2. Check if the probe is properly connected to the phenomenon being measured. 

3. Check if the oscilloscope probe is calibrated properly. If it is not calibrated, please 

follow the relevant instructions in the manual for calibration. 

19.3 No signal appears on the screen                   

1. Check if the probe is properly connected to the BNC connector of the signal input 

channel. 

2. Check if the channel is open (CH1-CH2 menu buttons). 

3. Check if there is signal output from the tested signal channel. 

4. If it is a DC signal with a relatively large amplitude, please increase the amplitude 

range. 

5. You can press the automatic measurement button to automatically detect the 

signal first. 

6. If there is still no waveform display, please contact the Hantai technical support 

department in a timely manner. 
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19.4 USB flash drive cannot be recognized             

1. Check if the USB flash drive is functioning properly. 

2. Confirm the capacity of the USB flash drive. It is recommended to use a USB 

flash drive that does not exceed 16GB for this oscilloscope. 

3. Confirm that the format of the USB flash drive is FAT32 format. 

4. Open the oscilloscope again and insert the USB drive for inspection. 

5. If you still cannot use the USB drive, please contact the Hantai technical support 

department in a timely manner. 

19.5 Waveform cannot be triggered                     

1. Check if the triggering data source is consistent with the signal input channel. 

2. Check if the trigger level is adjusted correctly. You can press the trigger level knob 

to return the trigger level to the signal center point. 

3. Check if the triggering method is correct, as the default triggering is edge 

triggering. For different input signals, the triggering method should be selected 

correctly. 
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20 Appendix                               

20.1 Appendix A: Accessories                            

Order information Order number 

Host model 

2GSa/S, 200MHz  

2-channel oscilloscope 
DSO2C20 

2GSa/S, 350MHz  

2-channel oscilloscope 
DSO2C35 

2GSa/S, 500MHz 

42-channel oscilloscope 
DSO2C50 

2GSa/S, 200MHz 

2-channel oscilloscope + AWG 
DSO2D20 

2GSa/S, 350MHz 

2-channel oscilloscope + AWG 
DSO2D35 

2GSa/S, 500MHz 

2-channel oscilloscope + AWG 
DSO2D50 

Standard accessories 

USB cable -- 

power Line -- 

Oscilloscope probe 

200MHz machine PP200B * 1 

350MHz machine PP300B * 1 

500MHz machine PP500B * 1 

Crocodile Clip Line 
DSO2C20 series * 1 

DSO2D20 series * 2 
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20.2 Appendix B: Warranty summary                       

Qingdao Hantek Electronic Co., LTD. (hereinafter referred to as Hantek) undertakes 

that the host and accessories of its production shall be free from any material and 

process defects during the warranty period. 

During the warranty period, if the product is proved to be defective, Hantek will repair or 

replace the product free of charge. Please refer to the description on Hantek official 

website for detailed warranty regulations. For repair service or full warranty instructions, 

please contact Hantek repair center or local offices. 

Hantek disclaims warranties, express or implied, other than those provided in this 

summary or any other applicable warranty card, including, but not limited to, any 

implied warranties of merchantability and fitness for special purpose. In no event shall 

Hantek be liable for indirect, special or consequential damages.
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